• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • 🏆 Hive's 6th HD Modeling Contest: Mechanical is now open! Design and model a mechanical creature, mechanized animal, a futuristic robotic being, or anything else your imagination can tinker with! 📅 Submissions close on June 30, 2024. Don't miss this opportunity to let your creativity shine! Enter now and show us your mechanical masterpiece! 🔗 Click here to enter!

Patch 1.30.9922 Hotfix

Status
Not open for further replies.
Screen Shot 2018-08-09 at 5.16.02 PM.jpg

Patch 1.30 Update

A quick fix has been pushed out to address the major issues with the 1.30 rollout!

Battle.net latency issues are fixed (they apparently went back to pre-1.28 levels). The -nativefullscr command line argument works again. And they've fixed an issue where custom abilities would crash if they had certain target fields selected.

Known issues: sounds will continue to be funky for a bit. It looks like mouse delay may still be there too, refer to this post to make a report.

Read the full list of changes here.
 

~El

~El

Level 17
Joined
Jun 13, 2016
Messages
559
One odd change I also noticed is that they changed the class name of the WC3 window. Previously it was `Warcraft III`, and now it is `OsWindow`. This isn't a huge change, but it broke a bunch of AutoHotkey scripts that my map used.
Sounds get totally mucked up if you use the mute sounds feature while in-game (Ctrl-S), which I personally use all the time. After turning the sounds back on, the following may or may not happen:
- Unit responses get turned on/off (even if they are off)
- Ambient map sounds get turned on/off
- Some spell/hit sounds become muted and don't play any more

While we're on the topic of sounds, it would be VERY helpful if they added an option to disable the default WC3 ambient >noise< that's heard when you open B.Net. It's extremely obnoxious and the only reason I mute the game at all, because it keeps playing even if you're tabbed out, and interferes with whatever music you have playing.

EDIT: Apparently, ticking off "Ambient sounds" in WC3 disables this noise, but I think it may also disable certain sounds in maps, though I'm not sure.
 
Last edited:

HB.

HB.

Level 3
Joined
May 6, 2017
Messages
44
The ping problem hasn't been fixed (I have an unstable ping of 120-200 in-game now, when in 1.29 I had 80-90).

And the sound still plays after minimizing the game.

Nice "fix".
 
Level 21
Joined
Dec 4, 2007
Messages
1,490
^ Come on now, that was a hotfix, you didn't expect everything to work from that, did you?
They broke their stuff before and got it back to working, so just a little patience is in order.

OT: They should add customizable inventory hotkeys soon, it's about time now!
 
Last edited:
Level 4
Joined
Dec 7, 2013
Messages
44
It crashes A LOT. The new sound system, "works", when you disable and enable everything in the sound options. But the crashing is a big deal breaker, I played 4 games, 4 crashes.

Edit: map is EotA, /whois EotaJou in any of the official servers, you can dl the map from there.
 
Last edited:
Level 2
Joined
Apr 6, 2017
Messages
18
I have an issue in 1.30, that windowed fullscreen is automatically set to 1920x1080x16, I cannot change it, it should be detected as 1920x1080x32 instead. I still can change it to the correct thing, if I use -nativefullscr instead.
 
Level 29
Joined
Jul 29, 2007
Messages
5,174
^ Come on now, that was a hotfix, you didn't expect everything to work from that, did you?
They broke their stuff before and got it back to working, so just a little patience is in order.

Considering 1.30 was on PTR for so long, you'd think such issues would be solved before it went public, and won't need a hotfix that only partially fixes some things (all game sounds are still broken, etc.) a day later. Feels like they made many changes right before making it public, and then rushed the patch for some reason without testing them on the PTR. Do Blizzard actually play the game, or only rely on users?

OT: They should add customizable inventory hotkeys soon, it's about time now!

+1

/edit
As an addendum to the question whether Blizzard play the game, I have seen multiple streamers who are getting more and more tired of the "balance" changes (some make sense, so many don't...) and are getting discouraged from even playing ladder. :(
 
Last edited:
Level 21
Joined
Dec 4, 2007
Messages
1,490
I think you are right
we are the testers.

But why not? If it's for the better of the game, i'm happy to help.
 

~El

~El

Level 17
Joined
Jun 13, 2016
Messages
559
Another interesting thing I found...
You can now launch multiple WC3 instances without a hassle! No need for any weird loaders or virtual machines.

Unfortunately, this is severely limited because it doesn't allow you to connect to LAN with more than one instance, which makes it virtually useless for testing maps. Whoops.
@Kam, could you guys look into this and see if you can get LAN to work with multiple game instances? This would help immensely with testing desyncs and other multiplayer stuff.
 
Level 23
Joined
Jul 26, 2008
Messages
1,321
So just out of curiosity, are any gameplay errors that occur to this patch attached to the editor itself? As in, is it not worth saving any campaign on this patch because the errors will stick to the editor, or is it only gameplay (so can save a campaign on 130XX and any issues will just resolve themselves.
 
Level 6
Joined
Jun 29, 2011
Messages
181
I simply cannot play. Mouse lag is too huge and opengl is not working anymore.

Seriously, even with mouse lag in 1.29, the rest was OK. Was there a reason of urgency to release this new patch instead of keep it testing in PTR?

I mean, we really love the new changes and improvements but there's no need to hurry onto releasing new patches that have not been tested fully. And come on, it's not the first time this is happening since the new wave of patches... We all thought it was already addressed this releasing issue...

The ping problem hasn't been fixed (I have an unstable ping of 120-200 in-game now, when in 1.29 I had 80-90).

And the sound still plays after minimizing the game.

Nice "fix".

I'm wondering if this has something to do with "Warden" being back.
 
Last edited:
Level 26
Joined
Feb 2, 2006
Messages
1,697
Please readd the possibility to use a custom War3Mod.mpq. It has been a useful feature for multiplayer modifications. Besides, removing the archives war3.mpq and war3.mpq etc. makes it harder/impossible for us to extract existing files. At the moment I can only see two big files called "data.000" and "data.001" in the directory "Warcraft III/Data/data". You are breaking compatibility to modifications which rely on modifying those archives as well as other tools. MPQ extractors are useless now.
 
Level 23
Joined
Jan 1, 2009
Messages
1,611
New issue since 1.30:
The sound option "Unit Responses" isn't properly saved. In the menu it's still deactivated, but after every restart the sounds are back.
If I reactivate and then deactivate them, it's silent again, but only till next restart.

@Barade Blizz hasn't shown any concern so far about breaking community tools - I doubt they will revert the move to casc.
 
Last edited:

HB.

HB.

Level 3
Joined
May 6, 2017
Messages
44
I have a stable ping 273 in-game now. It got even worse after the "fix". Before the patch it was 80. Completely unplayable.

It feels worse than in 2016.
 
Last edited:
Level 21
Joined
Dec 4, 2007
Messages
1,490
Please readd the possibility to use a custom War3Mod.mpq. It has been a useful feature for multiplayer modifications. Besides, removing the archives war3.mpq and war3.mpq etc. makes it harder/impossible for us to extract existing files. At the moment I can only see two big files called "data.000" and "data.001" in the directory "Warcraft III/Data/data". You are breaking compatibility to modifications which rely on modifying those archives as well as other tools. MPQ extractors are useless now.

That's actually huge... in a bad way.
 
Level 14
Joined
Jan 8, 2015
Messages
424
I noticed some random crashes to happen again with requirements, for some reason on really big maps with lots of units at ..pretty much random requirements on some stuff seen on the command bar of certain unit or building cause instant crash upon clicking that unit. It happened long ago to me when i added second altar for human heroes in my map that was switchable between original one and custom 2nd one via upgrades(one upgrading to one another to swap between lists of heroes).
It made person crash instantly after clicking on Keep....because of Castle requirement of altar........being on the command button grid.....when i removed the requirement it stopped the crashes from happening. I literally have no idea why suddently this happens......now it does for abilities on some units, i dunno if it has anything to do with 1.30. Maybe for some reason requirements get corrupted in some way if said thing is alternable...but then why it crashes with abilities now on single units? I fixed it by removing the requirements but its weird because spells were shared with other units. I suspect some kind of corruptions due to the size.... There were no crash messages.

If you want to test it - most recent version of my map from january(well aside from giant update for it i work on right now xD) has this on 2 units, Argent Cleric, trainable from Cathedral of light built by Argent dawn peasant in 2nd race chooser wisp and Undead skeletal mage from 1st Race choose wisp's Acolyte... Here is the link that version of the map: Link

Also there is a minor issue with race select/handicap being grayed out in multiplayer when hosted by a bot while it works in singleplayer(with locked teams and colours)
instead of being selectable race is locked to random while in singleplayer it works as intended with teams and colours locked and race selectable...

EDIT: Also i think that chat text should be moved to the right a tiny bit to clear out of the unused worker or heroes above 3 on the left of the screen.
EDIT2: These corruptions and crashes seem to connect with anything that is tranformable or tiered and used as a requirement hence my upgradeable altar req crash or current one with caster ability req with tiered upgrade for them.
 
Last edited:

Shar Dundred

Community Moderator
Level 72
Joined
May 6, 2009
Messages
5,878
I really want to know how this disaster with maps breaking, the mouse moving like shit, sounds etc. could even happen.

I mean, even if Blizz had not tested this patch at all, there was the PTR, right?
If it did have that issue, it would have been reported so it could've been fixed pre-release, right?
Did it just get changed in such a weird technical way that it broke so many things and no one thought "Let us test this and put it on the PTR before release"?

It baffles me how this patch, despite the PTR, is able to break the game like that.
I thought 1.29 with its breaking of requirements in the editor was bad, but oh boy, I was wrong.
 

Dr Super Good

Spell Reviewer
Level 64
Joined
Jan 18, 2005
Messages
27,229
I have an issue in 1.30, that windowed fullscreen is automatically set to 1920x1080x16, I cannot change it, it should be detected as 1920x1080x32 instead. I still can change it to the correct thing, if I use -nativefullscr instead.
Is it really operating in 16bit colour or is it just displaying that as a default value for the list? If using Windows 8 or 10 it should not even be able to use 16bit colour directly as that mode is no longer supported.

Do Blizzard actually play the game, or only rely on users?
I suspect they heavily test melee play. Looking at the changes I would not be surprised if they have dedicated staff just to play melee.

Custom maps is an entirely different ball game. It might just happen the ones tested, if any, did not crash. Simple test case maps to test out new or changed features might appear stable due to their simplicity and programmer bias. Additionally the current crashes being reported appear to be from long game times, something melee usually does not encounter due to its design.
At the moment I can only see two big files called "data.000" and "data.001" in the directory "Warcraft III/Data/data". You are breaking compatibility to modifications which rely on modifying those archives as well as other tools. MPQ extractors are useless now.
It is called CASC. All modern Blizzard games use it, and even non Blizzard ones like Destiny. A CASC viewer can be used to extract the files. Internally inside the CASC archive are folders named after the MPQs.
 
Level 29
Joined
Jul 29, 2007
Messages
5,174
I suspect they heavily test melee play. Looking at the changes I would not be surprised if they have dedicated staff just to play melee.

I understand you have the need to white knight blizzard on every occasion no matter what they do, here, on the blizzard forum, and no matter what game. All I can ask is please keep it to games you actually play, instead of saying crap.
It reached the point that even Neo is saying he is afraid of the balance changes that are being done, and he so far seemed almost as fanboyish as you.

And testing. Right. All game sounds are broken, something you'd see in less than a minute, if you were to actually play the game. But you don't, and neither does Blizzard. Give me a break.

I tried to play the game, have some fun 4v4s. It wasn't fun, all special effects didn't show up, an issue I never got in my life until this patch, and all game sounds didn't work. How fun playing a silent game. Then of course there's the fact even someone low level like me can't find a single 4v4 game without an instant leaver/tker/afker. But hey, it was tested.

Don't worry about it though, the expert team is on the loose. Pitlord has +1 agility, Blade Master has -1 agility, and Ancient Protectors now have 0.1 more attack speed when uprooted. Sounds like someone opened up excel, put some equations in, and looked mathematically at what "balances" out the stats, even though most of the changes make absolutely no sense in actual games.

And then there's the fact these changes are mostly geared towards 1v1 (many of which you can trace to "X popular user on twitch who cries about Y"), and completely break all team games and FFA.

I legitimately cannot understand you and other people who I don't think played warcraft 3 or ladder in years, if ever, and yet will argue for every single change that is done. Why be a mindless fanboy?
 
Last edited:
Level 6
Joined
Jun 29, 2011
Messages
181
I understand you have the need to white knight blizzard on every occasion no matter what they do, here, on the blizzard forum, and no matter what game. All I can ask is please keep it to games you actually play, instead of saying crap.
It reached the point that even Neo is saying he is afraid of the balance changes that are being done, and he so far seemed almost as fanboyish as you.

And testing. Right. All game sounds are broken, something you'd see in less than a minute, if you were to actually play the game. But you don't, and neither does Blizzard. Give me a break.

I tried to play the game, have some fun 4v4s. It wasn't fun, all special effects didn't show up, an issue I never got in my life until this patch, and all game sounds didn't work. How fun playing a silent game. Then of course there's the fact even someone low level like me can't find a single 4v4 game without an instant leaver/tker/afker. But hey, it was tested.

Don't worry about it though, the expert team is on the loose. Pitlord has +1 agility, Blade Master has -1 agility, and Ancient Protectors now have 0.1 more attack speed when uprooted. Sounds like someone opened up excel, put some equations in, and looked mathematically at what "balances" out the stats, even though most of the changes make absolutely no sense in actual games.

And then there's the fact these changes are mostly geared towards 1v1 (many of which you can trace to "X popular user on twitch who cries about Y"), and completely break all team games and FFA.

I legitimately cannot understand you and other people who I don't think played warcraft 3 or ladder in years, if ever, and yet will argue for every single change that is done. Why be a mindless fanboy?

I think you got a point here. But for me, the main question is: how after all these previous patch releases filled with bugs, haven't they improved their release process? I thought they already learnt after opening the PTR but it seems they didn't.
 
  • Like
Reactions: pyf
Level 5
Joined
Jul 15, 2015
Messages
118
Since 1.30 patch the game is unplayable for me...
Worse framerate, sounds are broken (they cut short, or are too loud or are simply ugly to hear or sounds that should be localized are heard across the map very loudly)!
:( Guess I'll go play something else (or even study! :D) for the time being.
 
Level 6
Joined
Jun 29, 2011
Messages
181
@Kam, there's another bug which was supposed to be fixed in 1.29.2.
  • Plugged the leak allowing Frozen balance into the Chaos bucket
This is still happening. In this patch, hunters in RoC are able to use Sentinel without upgrading it. And what it's worse: the upgrade is still in the AoW.

I don't know if this similar situation is happening in other changes introduced in TFT which shouldn't impact RoC.

Edit: yep, happening with hypporriders too.
 
Last edited:

Dr Super Good

Spell Reviewer
Level 64
Joined
Jan 18, 2005
Messages
27,229
all special effects didn't show up, an issue I never got in my life until this patch
Tried restarting your computer? No this is not a joke...

Over the last year or so a lot of people have reported this issue. It seems to mostly occur after graphic drivers have reached a very long up time, possibly playing many different games. It especially effects intel integrated graphics. It has become a big problem with Windows 10 because shutdown sends computers to hybrid sleep and does not reload the graphics driver.
and all game sounds didn't work. How fun playing a silent game
I cannot recreate this. All sound seems to be working fine for me, even music.
 

~El

~El

Level 17
Joined
Jun 13, 2016
Messages
559
Tried restarting your computer? No this is not a joke...

Over the last year or so a lot of people have reported this issue. It seems to mostly occur after graphic drivers have reached a very long up time, possibly playing many different games. It especially effects intel integrated graphics. It has become a big problem with Windows 10 because shutdown sends computers to hybrid sleep and does not reload the graphics driver.
I cannot recreate this. All sound seems to be working fine for me, even music.

Play some more, then. Game sounds are utterly broken. Sometimes certain sounds stop playing, sometimes certain sound settings get randomly flipped on/off, etc. He's not the only one having this issue.
 
Level 9
Joined
Apr 12, 2018
Messages
65
So...I dont think anyone else has reported this but oh well, is anyone else experiencing after the 1.30 release the crash image always appearing whenever you try to open warcraft 3? This weirdly happens on my old laptop yet not on my computer, dk, i play alot of wc3 on it. Like, i cant start wc3 without getting a crash instantly unless i run from admin, and for some reason the game runs slower, like i am even getting some small spikes in single player melee maps? Be it alternate or normal? Has anyone else experienced this?
 
Level 29
Joined
Jul 29, 2007
Messages
5,174
Tried restarting your computer? No this is not a joke...

Over the last year or so a lot of people have reported this issue. It seems to mostly occur after graphic drivers have reached a very long up time, possibly playing many different games. It especially effects intel integrated graphics. It has become a big problem with Windows 10 because shutdown sends computers to hybrid sleep and does not reload the graphics driver.
I cannot recreate this. All sound seems to be working fine for me, even music.

I remembered you mentioned it was the graphics driver needing a restart (which I cannot corroborate logically in any way, how is driver up time related in any way whatsoever to graphics code running on it, and if so how is wc3 the only game in existence where this is an issue?), thus I did an actual restart, plus manually restarted the graphics driver. My game is still SFX-less and audio-less. Even after playing the Settings puzzle mini-game by disabling/enabling the audio settings every time a game starts, most of the audio is gone. Feels pointless to play on this patch, it's not fun nor fair (I for one can't even tell half the time when I or my allies are getting attacked with no audio). Even watching streams became instantly so much less interesting with no audio.
 
Last edited:

Dr Super Good

Spell Reviewer
Level 64
Joined
Jan 18, 2005
Messages
27,229
I remembered you mentioned it was the graphics driver needing a restart (which I cannot corroborate logically in any way, how is driver up time related in any way whatsoever to graphics code running on it, and if so how is wc3 the only game in existence where this is an issue?), thus I did an actual restart, plus manually restarted the graphics driver. My game is still SFX-less and audio-less. Even after playing the Settings puzzle mini-game by disabling/enabling the audio settings every time a game starts, most of the audio is gone. Feels pointless to play on this patch, it's not fun nor fair (I for one can't even tell half the time when I or my allies are getting attacked with no audio). Even watching streams became instantly so much less interesting with no audio.
Could you make a demo map showing off what appear as missing special effects to you, including a description of which effects appear missing? It might be some pre-placed units, destructables, trigger created special effects, or ability cast created special effects. Such test map might be useful to track down the cause.
 
The special effect issue is because of animations not playing automaticaly anymore in some case.
"Birth" sequence does not play automaticaly upon special effect creation.
The animation that plays are "stand" and "death" upon destroying special effect.The other sequence type you have to use "play special effect specific animation" in trigger.
Effect won't display unless you make it play an animation.
 
Level 29
Joined
Jul 29, 2007
Messages
5,174
Uhhh, let's see, a test map...oh wait, it's every map, since the game is bugged.

Also I thought it was a graphics driver issue. Suddenly it depends on the map?

Does the audio not working also depend on the map? Maybe it's the sound driver that is just running for over 20 minutes already, so it must be bugged.

Come on man. Just stop it. Why comment things that are clearly wrong, when you don't even play the game to know better?
And when it's clear in a second this has nothing to do with some magical issue with graphics drivers that only affects a single game in existence. Exactly like all the rest of the bugs.

Then again, I don't know why I post here myself, since I don't see a single indication of Blizzard reading it or caring, here or on their own forum. Just fanboys who downvote everything they can on the Blizzard forum, or people complaining about bugs here and getting 0 replies.
Time will tell if their great approach of 0 PR and communication will go well for them. I myself think it's completely stupid and counter productive.
So much for getting people from the community into the classic team, finally we have some communication with Blizzard, right? right...?
 
Last edited:
3D sounds are still bugged. You can actually now set them in the Sound Editor but they do not play anymore in-game. I tried them with the Sound - Add 3D Sound Across Region Trigger Action. My test map is attached. There are two regions. One to the left and one to the right of the archmage. You should hear a sound, when you go near them, but nothing happens.

Also, custom movies play fine (when encoded to VP9 CQ), but the audio is a bit low. However, after you have played the custom movie, the game returns to the campaign main screen in a bugged mode. If you click any button, they do not work. The result is a permanent black screen as far as I can tell. You can download the test version of the Gnoll Campaign here. It has been modified to work with 1.30, that is, the movie is encoded in VP9 CQ AVI and the audio track is put into a separate mp3 file inside the campaign. The movie is also now inside the campaign file, so you do not need to install it separately anymore.
 

Attachments

  • 3dsoundtest2.w3m
    547.2 KB · Views: 112
Level 19
Joined
Dec 12, 2010
Messages
2,070
I understand you have the need to white knight blizzard on every occasion no matter what they do, here, on the blizzard forum, and no matter what game. All I can ask is please keep it to games you actually play, instead of saying crap.
It reached the point that even Neo is saying he is afraid of the balance changes that are being done, and he so far seemed almost as fanboyish as you.

And testing. Right. All game sounds are broken, something you'd see in less than a minute, if you were to actually play the game. But you don't, and neither does Blizzard. Give me a break.

I tried to play the game, have some fun 4v4s. It wasn't fun, all special effects didn't show up, an issue I never got in my life until this patch, and all game sounds didn't work. How fun playing a silent game. Then of course there's the fact even someone low level like me can't find a single 4v4 game without an instant leaver/tker/afker. But hey, it was tested.

Don't worry about it though, the expert team is on the loose. Pitlord has +1 agility, Blade Master has -1 agility, and Ancient Protectors now have 0.1 more attack speed when uprooted. Sounds like someone opened up excel, put some equations in, and looked mathematically at what "balances" out the stats, even though most of the changes make absolutely no sense in actual games.

And then there's the fact these changes are mostly geared towards 1v1 (many of which you can trace to "X popular user on twitch who cries about Y"), and completely break all team games and FFA.

I legitimately cannot understand you and other people who I don't think played warcraft 3 or ladder in years, if ever, and yet will argue for every single change that is done. Why be a mindless fanboy?
missing fx is old as fuck issue
https://i.imgur.com/L8TV4Jq.png

dont try to fight with DSG, he cannot be cured whatsoever
 
Level 12
Joined
Nov 3, 2013
Messages
989
The special effect issue is because of animations not playing automaticaly anymore in some case.
"Birth" sequence does not play automaticaly upon special effect creation.
The animation that plays are "stand" and "death" upon destroying special effect.The other sequence type you have to use "play special effect specific animation" in trigger.
Effect won't display unless you make it play an animation.
Just to make sure, is this exclusive to triggers, or is it for any special effect (e.g. basic abilities)?


This actually reminded me of how there's a lot of missile effects that look pretty good when attached to units, but I don't like their death animations since they're obviously meant for missiles, so they'll usually end with some explosion or such for when they hit their target. But that's generally not that fitting when you attach them to units with buffs.

So is there a way to skip certain animations now or how does it work?
 
Level 7
Joined
Jul 1, 2008
Messages
1,025
Actually we do... Many of the issues are being relayed onto them hence why I asked for a map which can easily recreate the problem in as quick as possible way.

I have my RPG map I can send, but it only seems to crash around 20 minutes in, and its one player at a time and would need to tested in multiplayer as I havnt been able to recreate the crash in singleplayer.

Would you need the unprotected version?

Interestingly I tested another version of it in multiplayer in which I had removed all sounds from the sound editor which the game uses, and it was alot more stable, we only lost 1 player 40 minutes into game.

My other custom game, Lordaeron the Foremath, now crashes while the map is loading for me, it can be found here:
https://www.epicwar.com/maps/281370/
LORDAERON: TF 0.27 - Warcraft 3 Maps - Epic War.com

Both maps were alot more stable before 1.30.
 

pyf

pyf

Level 32
Joined
Mar 21, 2016
Messages
2,985
[...] Then again, I don't know why I post here myself, since I don't see a single indication of Blizzard reading it or caring, here or on their own forum. Just fanboys who downvote everything they can on the Blizzard forum, or people complaining about bugs here and getting 0 replies.
Time will tell if their great approach of 0 PR and communication will go well for them. I myself think it's completely stupid and counter productive. [...]
@GhostWolf: better visit the Classic Games Support site (and its forum), than the Classic Games General Discussion forum which has unfortunately become a silly place imho.
 
Level 29
Joined
Jul 29, 2007
Messages
5,174
missing fx is old as fuck issue
https://i.imgur.com/L8TV4Jq.png

In case I wasn't clear, which is very possible, I know very well this is an old bug that was never fixed, like many others. I only mentioned it because it never happened to me in my life, no matter what patch, until now. I saw it happen plenty of times to other people on previous patches too.

The irony was too big, after not playing on bnet for a week or so, I come back just to have amazing silent games with no effects, and the usual instant leavers.

Do you play any other game that will randomly stop rendering things until you reinstall directx? But sure, it's a driver issue.............................................................................

Actually we do... Many of the issues are being relayed onto them hence why I asked for a map which can easily recreate the problem in as quick as possible way.

And yet here we are, with you suggesting that the bug is some irrelevant thing when it's clearly a bug with the game, or saying the balance changes make sense, when at the same time you don't actually play the game.
Because you know what? anyone actually playing on battle.net on this patch can repeat everything I wrote, but you come here just to "prove me wrong" and say that audio works for you. How helpful.
Same goes for previous patches, I just didn't bother writing here about their mess.
Are there some comments from Blizzard? then again, I don't know of anyone there who plays the game either, which is a huge issue to anything related to ladder, and why I keep repeating it (plus perhaps they'd actually realize literally all audio in the game is bugged before suddenly rushing to release a completely broken patch, hard to know basic things like that when you don't play).

Just to make sure, is this exclusive to triggers, or is it for any special effect (e.g. basic abilities)?
It's exclusive to special effect created with triggers.

No, it's not. It's a game wide bug.

@GhostWolf: better visit the Classic Games Support site (and its forum), than the Classic Games General Discussion forum which has unfortunately become a silly place imho.

I tried both in the past. I don't post on Blizzard's "forums" anymore. I've seen more mature comment sections on YouTube, as hard as that is to believe.
 
Last edited:
Level 12
Joined
Nov 3, 2013
Messages
989
And yet here we are, with you suggesting that the bug is some irrelevant thing when it's clearly a bug with the game, or saying the balance changes make sense, when at the same time you don't actually play the game.
To be fair, he's not necessarily saying what the problem is as much as he's saying that making a test map would make it easier to find *what* the problem is, and presumably how it occurs or whatever.

Even if they know that it doesn't work, it doesn't necessarily mean that they'll know why or how to fix it.
 
Then again, I don't know why I post here myself, since I don't see a single indication of Blizzard reading it or caring, here or on their own forum. Just fanboys who downvote everything they can on the Blizzard forum, or people complaining about bugs here and getting 0 replies.
Time will tell if their great approach of 0 PR and communication will go well for them. I myself think it's completely stupid and counter productive.
So much for getting people from the community into the classic team, finally we have some communication with Blizzard, right? right...?

I don't have much to say about the ladder changes because I don't play it all that much, but I do know that Blizzard seems to be touch with the modding community more than ever before. For one, they are taking backwards compatibility of maps into consideration, something I don't think they ever prioritized in the past. Furthermore, I was told personally by an employee at Blizzard that they are using the feedback thread on THW for their internal Q/A system and that they are reading posts. Not to mention the multiple bugs they have fixed as a result of members sharing demo maps with them. I (and others) have even been mentioned in the official patch notes for contributing.

During the release of 1.30, after everyone realized custom maps were broken, @Kam was asking for information regarding the crashes and a hotfix was released a day later. The fact the hotfix was released so quick is likely due to the communication with the community in realizing custom maps were unplayable. No, they didn't fix everything and yes, they do need better internal testing but to be fair the PTR was up for over a month and nobody reported any of these issues. It seems Blizzard over estimated how much developers were using the PTR. These issues would have been obvious fairly quickly had they done their own testing. In the future I think Blizzard will have to test popular custom maps before releasing a patch and not rely on the community to do so, which they probably should have done to begin with.

Overall I think they are communicating with the modding community pretty well. If anything they could use a community manager official to reliably respond to forum posts (CASC changes), and maybe a team to test maps.
 
Level 19
Joined
Dec 12, 2010
Messages
2,070
In case I wasn't clear, which is very possible, I know very well this is an old bug that was never fixed, like many others. I only mentioned it because it never happened to me in my life, no matter what patch, until now. I saw it happen plenty of times to other people on previous patches too.

The irony was too big, after not playing on bnet for a week or so, I come back just to have amazing silent games with no effects, and the usual instant leavers.

Do you play any other game that will randomly stop rendering things until you reinstall directx? But sure, it's a driver issue.............................................................................
I can definitely repeat this by letting my PC work for 30+ days, then due to timers overflow I won't see any effects. Reboot will fix this for me, but not for some others. Thats floating bug with no way to reproduce it by will. Other games work fine because their timers made properly? I guess. Whatever, in the end it's less irritating than the bug with inability to click anything.
 
Status
Not open for further replies.
Top