Dismiss Notice
60,000 passwords have been reset on July 8, 2019. If you cannot login, read this.

Weird Issue with Geosets

Discussion in 'Modeling & Animation' started by Mikekillkill, Feb 21, 2018.

  1. Mikekillkill

    Mikekillkill

    Joined:
    Jun 2, 2012
    Messages:
    25
    Resources:
    0
    Resources:
    0
    InTheModelEditor.png
    So here I have my model. (or well Wendigo reskinned to a Sasquatch, with the Necromancer Buck Skull as the head, with a ghoul ribcage)

    Originally upon first import into my testmap to test the model ingame, I came across this anomaly. The Issue.png
    When I initially gave it a move order, the two geosets I added remained floating in their starting location. As the original portions of the model moved with the unit. (The portrait did the same thing, as the model animated, the geosets just floated statically) Then after that, when I reloaded the map in the editor, I was greeted with a headless and ribcageless version of the model:
    In The Editor.png

    Then when I tested it again:

    Ingame.png

    The same headless ribless wendigo as in the editor, quite the anomaly.

    The tools I used to accomplish making the model in the first place are Vertexmodify (from Oinkertools) and War3ModelEditor (the one by Magos).

    All of the animations in the War3ModelEditor work as intended. (However the Death - Decay Flesh and Death - Decay Bone are literally the same, and I plan on reverting Death - Decay Bone to it's original value after I find the solution to the Geoset issue.)

    How would I go about fixing this? Would I merge the new geosets into the model's default geosets, and reskin it through Vertexmodify? Or is there another thing I could do in War3ModelEditor to fix the issue?

    (I attached the model in the attachments, so feel free to take a look for yourself, as it only uses ingame textures as of this moment.)
     

    Attached Files:

  2. GhostWolf

    GhostWolf

    Joined:
    Jul 29, 2007
    Messages:
    4,952
    Resources:
    2
    Tools:
    1
    Tutorials:
    1
    Resources:
    2
    All of the vertices of geoset 3 are attached to Bone_Head.
    All of the vertices of geoset 4 are attached to Bone_Chest.
    Neither of these nodes are bones - they are helpers.
    Vertices must be attached to bones.

    Use the sanity tester :p
     
  3. Mikekillkill

    Mikekillkill

    Joined:
    Jun 2, 2012
    Messages:
    25
    Resources:
    0
    Resources:
    0
    Thanks for finding the problem, I appreciate it. I'll attach the vertices to their respective bones immediately! C: