1. Updated Resource Submission Rules: All model & skin resource submissions must now include an in-game screenshot. This is to help speed up the moderation process and to show how the model and/or texture looks like from the in-game camera.
    Dismiss Notice
  2. DID YOU KNOW - That you can unlock new rank icons by posting on the forums or winning contests? Click here to customize your rank or read our User Rank Policy to see a list of ranks that you can unlock. Have you won a contest and still havn't received your rank award? Then please contact the administration.
    Dismiss Notice
  3. The poll for Hive's 12th Concept Art Contest is up! Go cast your vote for your favourite genie!
    Dismiss Notice
  4. Travel to distant realms and encounter scenes unknown to the common folk. The Greatest of Adventures is upon us with the 8th Cinematic Contest. Join in on a fun ride.
    Dismiss Notice
  5. The 18th Icon Contest is ON! Choose any ingame unit and give him/her Hero abilities. Good luck to all.
    Dismiss Notice
  6. Contestants are to create a scene set in the Stone Age. Come and see what you can come up with. We wish you the best of luck!
    Dismiss Notice
  7. Colour outside the lines! Techtree Contest #13 is a go. The contest is optionally paired.
    Dismiss Notice
  8. Greetings cerebrates, our Swarm needs new spawners that will have numerous children. Join the HIVE's 31st Modeling Contest - Spawners and Spawned! The contest is optionally paired.
    Dismiss Notice
  9. Check out the Staff job openings thread.
    Dismiss Notice
Dismiss Notice
60,000 passwords have been reset on July 8, 2019. If you cannot login, read this.

Should I keep making maps for 1.26 vs 1.28?

Discussion in 'Patch & Reforged Discussion' started by daverave1212, Mar 24, 2018.

  1. daverave1212

    daverave1212

    Joined:
    Apr 9, 2010
    Messages:
    407
    Resources:
    2
    Tools:
    1
    Tutorials:
    1
    Resources:
    2
    For mapmakers out there...
    What version are you mapping on?
    I used 1.26 until recently when I switched to 1.28 when I started playing/modding warcraft again after a long break.
    Is it better to make maps on 1.26 vs 1.28?
    I noticed I can open 1.28 maps in 1.26 world editor/JNGP, but I can't play a map on 1.26 anymore if I saved it at least once in 1.28.
    Are there still platforms using 1.26?
    Thanks!
     
  2. TriggerHappy

    TriggerHappy

    Code Moderator

    Joined:
    Jun 23, 2007
    Messages:
    3,659
    Resources:
    22
    Spells:
    11
    Tutorials:
    2
    JASS:
    9
    Resources:
    22
    I'm am mostly using 1.28.5 but I also use 1.29 PTR.

    It depends what you mean by better. Technically 1.26 has more available resources but 1.28 is the newest where you can play on battle.net.

    You must be doing something wrong because most or all of my maps work in 1.26 and 1.28.5.

    I think w3arena is still using 1.26, however netease is using 1.27b and they are planning to upgrade to 1.29.
     
  3. daverave1212

    daverave1212

    Joined:
    Apr 9, 2010
    Messages:
    407
    Resources:
    2
    Tools:
    1
    Tutorials:
    1
    Resources:
    2
    Thanks for the answer
    I double checked and it seems to be a problem only on certain maps.
    There's a certain map that I started in 1.28 and I noticed the map didn't appear in the 1.26 Warcraft III maps list in game.
    So I opened the 1.28 map in 1.26 World Editor and made a clean save of it ('save as').
    I still couldn't play it in 1.26.
     
  4. DracoL1ch

    DracoL1ch

    Joined:
    Dec 12, 2010
    Messages:
    1,758
    Resources:
    2
    Tutorials:
    2
    Resources:
    2
    dota platforms -> 26/any other patches
    official bnet -> official patches
    where are your players? get to know them first, then decide
     
  5. Kyrbi0

    Kyrbi0

    Joined:
    Jul 29, 2008
    Messages:
    7,838
    Resources:
    1
    Models:
    1
    Resources:
    1
    I still use 1.26 to mod; I love the new stuff & keep an updated copy elsewhere on my computer, but until the 'storm' dies down (changes & such, exploits & potential breakdowns/errors/mistakes, etc), it just seems safer to mod on an earlier version for now.
     
  6. daverave1212

    daverave1212

    Joined:
    Apr 9, 2010
    Messages:
    407
    Resources:
    2
    Tools:
    1
    Tutorials:
    1
    Resources:
    2
    thanks for the answers all!