• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • ✅ HD Level Design Contest #1 POLL is now OPEN! Check out the stunning visuals of the final entries. 🔗Click here to cast your vote!

Problems with JNGP

Status
Not open for further replies.
Level 1
Joined
Jun 10, 2011
Messages
2
I have set up JNGP as per the instructions on this forums, including updating
the native list. Most of the code I have written works without issues and I
had no problems with executing my functions and the worked how I wanted
hem to work.

When I got to the point when I wanted to test struct, libraries and scopes I
encountered quite an obstacle. It seems that whenever any of these are in
my code it simply won't compile. When I check syntax the response is
"syntax error" and three additional entries of "Statement outside of function"
for the same line.

Saving the map gives no errors and when I try to test the map I get to the
main menu of wc3tft. Selecting the map in custom game shows no available
player slots for the map.

The only time any of these statements worked was when I tried one of the
demo maps included in the JassHelper folder. The syntax check still reported
problems, but saving the map worked and I could run it nonetheless.

I tried to copy all the triggers from the "interfaces.w3x" into a new map and
it doesn't work. I tried adding any of the three statements to a completely
new map and it doesn't work.

I am running it on a pc with win 7 ultimate. I tried running the editor in
compatibility mode for win xp sp3 and all the same errors still apply.

I would greatly appreciate it if anyone would be able to tell me what I am
doing wrong so that I can continue with my project. I have spent the last
hour just searching the site for similar cases, but to no avail.

Thanks a lot
/Durk
 
Level 1
Joined
Jun 10, 2011
Messages
2
Thank you for your quick response, as I mentioned it isn't about a specific map or a specific piece of code. It is simply about trying to use structs, libraries or scopes. Adding them to the code simply doesn't work for some reason, and I think it is a software error since declaring structs, scopes or libraries with or without simple variables still prevents the compilation.

When I write struct, library or scope they become bold just as if using any known variable type, same with the endstruct/endlibrary/endscope. But when I do a syntax check it doesn't recognize them.

errormessagei.png


This is a piece of code I added to an empty new map and as you can see the struct contains nothing by two private integer variables, basically a copy from the JassHelper documentation.

For some reason it finds script errors, which it shouldn't as far as I know. And when I try to save, it works and gives no errors. When I try to test it, I get sent to the main menu of wc3 and in custom game it appears without player slots and doesn't load.

Thanks alot
/Durk
 
Status
Not open for further replies.
Top