Newbie witht the WC3 Editor (Jass NewGen) is searching help

Level 1
Joined
Jun 21, 2014
Messages
7
Hi everyone,

yes i'm new here and searching for help because i don't have much experience with the Editor of WarCraft III:
I have obtained an unprotected version of the map Civilization Wars and would like to continue it officially, but always get a couple of errors already when i start with UMSWE enabled:

[TriggerActions] - SaveWidgetHandleBJ
[TriggerActions] - SaveAbilityHandleBJ
[TriggerActions] - SaveTriggerEventHandleBJ
[TriggerActions] - SaveRegionHandleBJ
[TriggerActions] - SaveUnitPoolHandleBJ
[TriggerActions] - SaveItemPoolHandleBJ
[TriggerActions] - SaveMultiboardItemHandleBJ
[TriggerActions] - SaveTrackableHandleBJ

Since the map was made with UMSWE, i don't know how load unless enabling it. But when i'm trying to change something (even minimal changes like only saving to another file), it is not playable later when i start WC3. Already asked for a help at the site where i downloaded the JAssNewGen Pack (http://blizzardmodding.info/) but the problem still exists.
I'm using Windows 7, Jass NewGen 2.0.0.7 and Warcraft III is patached (current version 1.26).


Can you help please?
 

Kazeon

Hosted Project: EC
Level 33
Joined
Oct 12, 2011
Messages
3,443
[TriggerActions] - SaveWidgetHandleBJ
[TriggerActions] - SaveAbilityHandleBJ
[TriggerActions] - SaveTriggerEventHandleBJ
[TriggerActions] - SaveRegionHandleBJ
[TriggerActions] - SaveUnitPoolHandleBJ
[TriggerActions] - SaveItemPoolHandleBJ
[TriggerActions] - SaveMultiboardItemHandleBJ
[TriggerActions] - SaveTrackableHandleBJ
That's normal. Also happens here.

When i open the file with JNGP and run it with the test option (CTRL + F9) it works, but when i edit a small thing or simply save the existing file to another file, it doesn't anymore.
What causes this? Does aynone know a solution?

You need to save before testing your map. And TESH (in the trigger editor) is able to save your last scroll position and the position is written in the trigger so it automatically modifies your trigger when you scroll up/down, so you need to save again even if you have just scrolled it a bit. But it doesn't occur when you are using GUI so don't worry.

For better idea, you can see at the top of your WE (terrain editor), there is your map filepath and it's name written there. When it appears a '*' after the file name, then it means you have to save first before testing.

Hope it helps.
 
Level 1
Joined
Jun 21, 2014
Messages
7
Tahnks for your replies, but i'm still having the same problem:

Daffa the Mage said:
I assume the map from older version (below 1.24)?
If so, then the Patch 1.24+ kills the map as they fix Handle exploit.

The release was 2 or 3 years ago and since then it has being autohosted on several bots at battle.net (ent16 for example). My Warcraft III is updated to the current patch.

Dalvengyr said:
You need to save before testing your map. And TESH (in the trigger editor) is able to save your last scroll position and the position is written in the trigger so it automatically modifies your trigger when you scroll up/down, so you need to save again even if you have just scrolled it a bit. But it doesn't occur when you are using GUI so don't worry.

For better idea, you can see at the top of your WE (terrain editor), there is your map filepath and it's name written there. When it appears a '*' after the file name, then it means you have to save first before testing.

Hope it helps.

I've tried to save it and then test it, but still doesn't load. Also i don't see that * in the filename. Maybe providing a screenshot will give for information to solve the problem. This is the setup with UMSWE enabled that runs properly, just when i start editing it does not anymore (using a German version of the editor, if you need any translation let me know):
 

Attachments

  • wc3 editor.jpg
    wc3 editor.jpg
    574.2 KB · Views: 166
Last edited:
Top