Error when opening map

Level 4
Joined
Jun 13, 2010
Messages
114
When I try to open my map with JNGP on other PCs I get this error.

"Trigger function does not exist in database.: DestroyTrigger"


If I start up JNGP on my PC I get this errors but after that I can open up every map normal.

[TriggerActions] - SaveWidgetHandleBJ
[TriggerActions] - SaveAbilityHandleBJ
[TriggerActions] - SaveTriggerEventHandleBJ
[TriggerActions] - SaveRegionHandleBJ
[TriggerActions] - SaveUnitPoolHandleBJ
[TriggerActions] - SaveItemPoolHandleBJ
[TriggerActions] - SaveMultiboardItemHandleBJ


If I disable UMSWE those errors at start up disappear but then I get the same error I posted on top when I try to open my map.

Here is my map if it helps
http://www.mediafire.com/download/1h2e2x61xud5mm2/Blade+Dynasty+0.47.w3x

thx in advance
 
Level 4
Joined
Jun 13, 2010
Messages
114
make sure Wc3 is also installed there, and is updated to latest version

and also make sure your JNGP is updated

I play in battle.net so my wc3 version should be newest.
My JNGP is 5d.
I've put my JNGP and Wc3 into same path now but still same errors.

:goblin_cry:
 
It means you used UMSWE/WEU or EGUI while creating the map. You have to have UMSWE enabled when opening it for the functions to load properly.

So.. checkmark Enable UMSWE. Wait a little bit for it to generate the MPQ (it should just hang for a few moments), and then close and reopen the editor. Then try opening your map. If you get errors when you tick "Enable UMSWE", post them.

P.S. How long ago did you edit the map? Did you create the map recently, or is it a map you worked on a long time ago and are now trying to open?
 
Level 4
Joined
Jun 13, 2010
Messages
114
It means you used UMSWE/WEU or EGUI while creating the map. You have to have UMSWE enabled when opening it for the functions to load properly.

So.. checkmark Enable UMSWE. Wait a little bit for it to generate the MPQ (it should just hang for a few moments), and then close and reopen the editor. Then try opening your map. If you get errors when you tick "Enable UMSWE", post them.

P.S. How long ago did you edit the map? Did you create the map recently, or is it a map you worked on a long time ago and are now trying to open?

I started the map 2011 and was able to open it.
Now after I edited my map lately and added new stuff to it, I can't open the map on other computers anymore. Only on my own one.

I activated UMSWE on both of my computers and used the identical JNGP 5d versions but on my other one I keep getting this error: "Trigger function does not exist in database.: DestroyTrigger"


Im afraid that If I reinstal wc3 or when I have to instal windows new or something that I wont be able to edit my map anymore at all.
 
Level 4
Joined
Jun 13, 2010
Messages
114
You can always save a back up of all maps first before you reinstall...

PS: all of those other computers has updated wc3 too right?

Also try running as admin in case you didn't


Checked right now and my other computer has updated wc3 aswell.
Runing as admin just gave me same error.
 
Top