Jass newgen UMSWE help

Level 2
Joined
Aug 31, 2009
Messages
21
Hello,

I want to use the Jass newgen editor to make the village rock tile unwalkable.
I used UMSWE but it doesn't seem to work.
Here is what I have done:

Enabled UMSWE
Customised the tile pathability of village rock to unwalkable
Enabled Custom tile pathability
Saved the map
Closed and restarted the editor
Opened the map

But when I test the map my units can still walk over the tile. The version of newgen I used is 2.0.7. I have also tried to reinstall jass newgen with my anitvirus disabled and opening it as administrator.
 
Level 13
Joined
May 11, 2008
Messages
1,198
Before saving and testing it, try planting ground units on the map with the unit layer. Then try dragging them onto your special rock. If they are where they shouldn't be, keep at it. Units will disappear if they are on unwalkable terrain, even if that is just a cliff.
 
Level 23
Joined
Apr 16, 2012
Messages
4,041
you did one useless step.

The correct order of operation is:

Enabled UMSWE
Customised the tile pathability of village rock to unwalkable
Enabled Custom tile pathability
Closed and restarted the editor
Opened the map


You dont save map, because UMSWE will save the map for you, but the editor will not acknowledge the change, so when you save the map, you overwrite any changes made by UMSWE(the tile is again walkable)
 
Level 2
Joined
Aug 31, 2009
Messages
21
Okay I tried it a couple times using the order you said, but it still won't work. In the UMSWE it does however say that the tile is unwalkable when i open the map.
In the editor I can also just place the units on the tile.
 
Level 13
Joined
May 11, 2008
Messages
1,198
Try planting the tile again is the only other suggestion I can think of. It's possible that the tile you have down already is another kind of tile that you don't need. It's hard to know how to help some of these stories as it's impossible to tell us the full details of your story easily.
 
Level 2
Joined
Aug 31, 2009
Messages
21
I made a new map and tried to use it on different tiles, they all don't work. In UMSWE it says though that all the tiles are unwalkable, it doesn't reset. I've also tried to install an older version of newgen but that also didn't work. The other features of newgen do however work, i'm only having problems with UMSWE.
I'm also 100% certain that I changed the right tiles.
 
Top