• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • ✅ Time to vote for the top 3 models! The POLL for Hive's 6th HD Modeling Contest: Mechanical is now open! 📅 Poll close on July 16, 2024! 🔗 Cast your vote now!
  • ✅ The POLL for Hive's Texturing Contest #33 is OPEN! Vote for the TOP 3 SKINS! 🔗Click here to cast your vote!

Custom sounds not working! :(

Status
Not open for further replies.
I bet this has been asked a million times here, but i swear i've looked up both tutorials and previous threads without success.

I have replaced a few sounds in a sound set, but when i test the map they refuse to play. It's just quiet where there should be a sound.

First i tried uploading them in the import manager as mp3's (was hoping for it to work since waves are so huuge), i'm sure i had the path right, but it didn't work.

Then i exported them as waves instead (i use audacity) but still nothing.
My waves are 16-bit 128kbps.

What am i doing wrong?
 
As i just said: If there was an error in the path, it wouldn't overwrite the original sound!
My problem is that instead of getting a new voice, the units using the sound sets get all silent.
Does it have something to do with the bitrate?
And also, when i overwrite the sounds with mp3, i set the path to the exact one, with .wav in the end, even though it's actually a .mp3. Is that possible?
 
Level 9
Joined
Feb 3, 2006
Messages
326
Basically i set it as a trigger when UNIT is issued a command to attack an enemy. It worked fine first try..
This is basically what i meant, i'm not sure u can overwrite other sounds in a sound set... but i dont know for sure
 

Attachments

  • Attacksound Test.w3m
    50.7 KB · Views: 122
I dont have the OPTION to make them 3d - i simply import sounds into the import manager, using a sound path from an ingame sound in order to overwrite it!

My problem is as follows:
*I have an mp3 sound that i want to use.
*I import it to an existing sound path, for example units\human\footman\FootmanWhat1.wav (or .mp3, i have tried both)
*The sound successfully overwrites the old sound, but is not played!
Instead there is just void where the sound should be. It's so annoying!

If i import them regularly, and use them in a triggered function, they play. But not otherwise.
 
Status
Not open for further replies.
Top