• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • 🏆 Hive's 6th HD Modeling Contest: Mechanical is now open! Design and model a mechanical creature, mechanized animal, a futuristic robotic being, or anything else your imagination can tinker with! 📅 Submissions close on June 30, 2024. Don't miss this opportunity to let your creativity shine! Enter now and show us your mechanical masterpiece! 🔗 Click here to enter!

3d sounds wont work

Status
Not open for further replies.
Level 30
Joined
Jul 23, 2009
Messages
1,029
I tried to make a trigger play a 3d Sound at the point of a dying unit but it won't work even if I check "3d sound" in the sound variable tick box.

  • Templar Death
    • Events
      • Unit - A unit Dies
    • Conditions
      • (Unit-type of (Triggering unit)) Equal to (==) Templar
    • Actions
      • Sound - Play Garen_dying2 <gen> at 100.00% volume, attached to (Triggering unit)
It DOES play the sound when I uncheck the "3d sound" box. But I don't want everyone on the map to hear it if they don't even monitor the location where he dies.

This is how the variable looks like.
Even if the min distance is above 0 it doesn't work so that's not the problem I guess.

D2PJd.png
 
Level 16
Joined
Mar 27, 2011
Messages
1,349
Well, logically, a 3d sound is a sound which plays at a point. If the sound does not "stop when out of range" then it isnt really a 3d sound. Try ticking the box and see what happens, also setting the min and max cutoff distances.
 
Level 11
Joined
Sep 14, 2009
Messages
284
Do it like this:

  • Templar Death
    • Events
      • Unit - A unit Dies
    • Conditions
      • (Unit-type of (Triggering unit)) Equal to (==) Templar
    • Actions
      • Set TempPoint = (Position of (Triggering unit))
      • Sound - Play Garen_dying2 <gen> at 100.00% volume, located at TempPoint with Z offset 0.00
      • Custom script: call RemoveLocation (udg_TempPoint)
And also check the box "Stop when out of range".
The sound settings should be like this for death sounds:
Min distance: 600
Max distance 10000
Distance cutoff: 3000
 
Status
Not open for further replies.
Top