• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • 🏆 Hive's 6th HD Modeling Contest: Mechanical is now open! Design and model a mechanical creature, mechanized animal, a futuristic robotic being, or anything else your imagination can tinker with! 📅 Submissions close on June 30, 2024. Don't miss this opportunity to let your creativity shine! Enter now and show us your mechanical masterpiece! 🔗 Click here to enter!

Visibility problem

Status
Not open for further replies.
Level 11
Joined
Sep 14, 2009
Messages
284
Hi. Is there any way to disable "Advanced Options > Visiblity" settings before launching a map? I don't want players to be able to use the options "Always visible" or "map explored".

Triggers won't do. Enabling visibility modifier with black mask leaves explored areas black, which I don't want.
"Map Options > Masked areas are partially visible" does not prevent players from selecting the advanced options, so this won't do either.

Any ideas?
 
Unit won't attack when they lack sight, regardless if they're in acquisition range (experienced this). Provoked unit still retaliates though.

Unless you make the unit loss their sight when inside, but grant them ~200 range of vision manually so they can see themselves and around them so they can attack.
 
Level 11
Joined
Sep 14, 2009
Messages
284
I think you should use the enable black and Visibility modifier mask and THEN Disable them.

Like this? It didn't work. It leaves the whole map explored.

  • Initialization
    • Events
      • Map initialization
    • Conditions
    • Actions
      • Visibility - Enable black mask
      • Visibility - Create an initially Enabled visibility modifier for Player 9 (Gray) emitting Black mask across (Playable map area)
      • Visibility - Disable (Last created visibility modifier)
      • Visibility - Disable black mask
      • Custom script: call DestroyTrigger(GetTriggeringTrigger())
EDIT: Ok. I removed the "Visibility - Disable black mask" and it now works for the option "Always visible", but not for the "Map explored". Very strange.

Still looking for solutions.
 
Last edited:
Status
Not open for further replies.
Top