• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • 🏆 Hive's 6th HD Modeling Contest: Mechanical is now open! Design and model a mechanical creature, mechanized animal, a futuristic robotic being, or anything else your imagination can tinker with! 📅 Submissions close on June 30, 2024. Don't miss this opportunity to let your creativity shine! Enter now and show us your mechanical masterpiece! 🔗 Click here to enter!

Problem Starting up World Editor

Not open for further replies.
Level 1
Sep 22, 2010
I bought myself a new tower computer, installed WC3 and i can't open The World editor.
I can open the games reign of chaos and frozen throne.
When i open world editor a smal invisible window pops up, where my mouse is trapped in.
After a while of if i klick, the window disappears and nothing happens.

I tried the world editor on an older laptop and my previous pc and it works.
I tried every patch, tried a crack, started everything with full acces, nothing works.
I want to use the classic warcraft 3 game ;) so i patched it now till 1.27b

PC info: processor: Windows 10 Home
Processor AMD Ryzen 5 2600 Six-Core 3.40 Ghz
64 bits system
NVIDIA Geforce GTX 1650
Warcraft is installed on my SSD

Can Someone help me?
Not open for further replies.