• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • ✅ Time to vote for the top 3 models! The POLL for Hive's 6th HD Modeling Contest: Mechanical is now open! 📅 Poll close on July 16, 2024! 🔗 Cast your vote now!
  • ✅ The POLL for Hive's Texturing Contest #33 is OPEN! Vote for the TOP 3 SKINS! 🔗Click here to cast your vote!

JNGP Help. Not working.

Status
Not open for further replies.
Level 8
Joined
Jun 18, 2007
Messages
214
Hello everyone. I've being using the standard JASS for quite some time now. I've tried to implement JNGP numerous time, and I can't get it to work.

Here is what I did:

- Downloaded Jass Newgen Pack 1.5d from The Helper.
- Installed it in a folder (which is not in WC3)
- Downloaded Jass Helper 0.9.K version from The Helper.
- Replaced the files from the JHelper in JNGP with the new ones.
- Started JNGP with New Gen WE (if I start it with NewGen Warcraft it gives me error: Could not hack game.dll. Please post logs/ongameload.txt)
- It's opened, and I can see the extensions (UMSWE, Grimoire, JassHelper, Reinventing the Craft)
- I can see the triggers, and once they are in JASS, the JNGP functions are working.
- Now I can save it, but If I try to test the map in any way it completely crashes my WC3.

I need to know how can I test it without crashing, what do I have to disable?
I'm using latest version of Wc3 (1.24b).

P.S. I don't know should this thread be posted here.

EDIT: When I disable Reinventing the Craft, I can test the maps, but it sends me to menu screen, even if I saved it before testing.
 
Last edited:
Make sure you have the latest patch (1.24b).
Some spells may not be able to be played in the latest patch (Not your fault).
Before testing, save map with "Save", not with "Save as". (Press control + S to save).

Make sure you have RtC disabled.
Make sure the JassHelper and JNGP are updated.
Make sure you are using the right wc3 install folder.
Make sure the map you are using isn't broken.
Make sure wc3 is installed cleanly without any problems.
 
Level 8
Joined
Jun 18, 2007
Messages
214
Make sure you have the latest patch (1.24b).
Some spells may not be able to be played in the latest patch (Not your fault).
Before testing, save map with "Save", not with "Save as". (Press control + S to save).

Make sure you have RtC disabled.
Make sure the JassHelper and JNGP are updated.
Make sure you are using the right wc3 install folder.
Make sure the map you are using isn't broken.
Make sure wc3 is installed cleanly without any problems.

Yes, I know for saving, and I always save it like that before testing. Spell I tested are working with the new patch. I can test them in ordinary WE but not with vJass.

- RtC is disabled
- JassHelper and JNGP are all the newest version
- I think I am using. But I wouldn't be able to start JNGP at all if it wasn't.
- It's not I stated in the upper post
- It's original WC3 and it's installed without any errors or problems

Thanks for commenting I will try all of this again.
 
- RtC is disabled
- JassHelper and JNGP are all the newest version
- I think I am using. But I wouldn't be able to start JNGP at all if it wasn't.
- It's not I stated in the upper post
- It's original WC3 and it's installed without any errors or problems
Hmm... For me it looks like Wc3 Version is wrong. Did you really install the latest version?

If nothing works, reinstall wc3, reinstall TFT, reinstall JNGP and replace JassHelper, disable RtC and it should work.

Else you should post a thread on wc3c.net with your system specifications.
 
Status
Not open for further replies.
Top