1. Updated Resource Submission Rules: All model & skin resource submissions must now include an in-game screenshot. This is to help speed up the moderation process and to show how the model and/or texture looks like from the in-game camera.
    Dismiss Notice
  2. DID YOU KNOW - That you can unlock new rank icons by posting on the forums or winning contests? Click here to customize your rank or read our User Rank Policy to see a list of ranks that you can unlock. Have you won a contest and still havn't received your rank award? Then please contact the administration.
    Dismiss Notice
  3. Travel to distant realms and encounter scenes unknown to the common folk. The Greatest of Adventures is upon us with the 8th Cinematic Contest. Join in on a fun ride.
    Dismiss Notice
  4. The 18th Icon Contest is ON! Choose any ingame unit and give him/her Hero abilities. Good luck to all.
    Dismiss Notice
  5. The Secrets of Warcraft 3 have revealed interesting works. The RESULTS for Abelhawk's Mini-Mapping Contest #15 have come out!
    Dismiss Notice
  6. Contestants are to create a scene set in the Stone Age. Come and see what you can come up with. We wish you the best of luck!
    Dismiss Notice
  7. Colour outside the lines! Techtree Contest #13 is a go. The contest is optionally paired.
    Dismiss Notice
  8. Night Rider gained several songs for his journey. The poll for the 12th Music Contest has started. Check it out!
    Dismiss Notice
  9. Greetings cerebrates, our Swarm needs new spawners that will have numerous children. Join the HIVE's 31st Modeling Contest - Spawners and Spawned! The contest is optionally paired.
    Dismiss Notice
  10. Check out the Staff job openings thread.
    Dismiss Notice
Dismiss Notice
60,000 passwords have been reset on July 8, 2019. If you cannot login, read this.

youtube not showing up anymore on UC browser (pc)

Discussion in 'Computer Tech' started by [E]clipse, Feb 13, 2016.

  1. [E]clipse

    [E]clipse

    Joined:
    Jan 6, 2015
    Messages:
    559
    Resources:
    0
    Resources:
    0
    hello everyone,
    I use a windows 7 PC and ive been using UC browser for a long time when suddenly I see that youtube pages are not loading anymore and I have not the slightest idea why this happened.

    I everything worked perfectly till a few minutes ago and now whenever i try to visit youtube all I get is a blank screen.

    However, google chrome runs it quite well. THough i want to use it on UC since UC is much better to me.

    Any help appreciated. Thanks.
     
  2. Warseeker

    Warseeker

    Joined:
    Feb 18, 2014
    Messages:
    2,410
    Resources:
    1
    Maps:
    1
    Resources:
    1
    Does JavaScript still active?
     
  3. [E]clipse

    [E]clipse

    Joined:
    Jan 6, 2015
    Messages:
    559
    Resources:
    0
    Resources:
    0
    Yes warseeker
     
  4. Warseeker

    Warseeker

    Joined:
    Feb 18, 2014
    Messages:
    2,410
    Resources:
    1
    Maps:
    1
    Resources:
    1
    Do you have a protection system on your browser?
     
  5. [E]clipse

    [E]clipse

    Joined:
    Jan 6, 2015
    Messages:
    559
    Resources:
    0
    Resources:
    0
    Well, protection systems ?
    Nope... i had some that i removed but again, that was long before and youtube still worked fine, this is happening just recently
     
  6. Dr Super Good

    Dr Super Good

    Spell Reviewer

    Joined:
    Jan 18, 2005
    Messages:
    25,429
    Resources:
    3
    Maps:
    1
    Spells:
    2
    Resources:
    3
    Try fully restarting the browser (close its process). If that does not work try fully restarting the PC.

    If that does not work, try installing/reinstalling the latest version of the browser.