[RenderEdge] Widescreen Fix

This bundle is marked as approved. It works and satisfies the submission rules.
Current version v1.2.0c

A standalone version of RenderEdge with only widescreen fix.

Adds support for monitors with aspect ratios wider than 4:3.


Installation:

Put the .mix file from archive into the folder where WarCraft III is installed.


Requirements:

Supported patches:
  • 1.28.0, 1.28.2, 1.28.4, 1.28.5;
  • 1.27a, 1.27b;
  • 1.26a;
  • 1.24e;
  • 1.23a.

Source code:
GitHub
Contents

[RenderEdge] Widescreen Fix (Binary)

Reviews
eejin
Works correctly, is easy to install and makes Warcraft look better on widescreens. Approved!

eejin

Tool Moderator
Level 11
Joined
Mar 6, 2017
Messages
214
Seems to work correctly and installation is also as simple as it gets. For approval do please upload the .mix straight to the Hive workshop or in a normal .zip as some users might not be able to open .rar files.
 
Level 7
Joined
Jun 5, 2018
Messages
175
RenderEdge is a famous and great program, as we know. The experimental and basic versions have been well known by modders and players. Now we really desire a formal release of RenderEdge with fully developed features, not the experimental or basic.

Please continue your excellent work. The world is waiting for it.
 

pyf

pyf

Level 31
Joined
Mar 21, 2016
Messages
2,986
This fix puts Blizzard and their first official widescreen solution (introduced on March 2011 with Patch 1.25b) to shame.

Also, amazing support by the developer for previous OSes and game versions (nine, no less!).


All in all, simply outstanding and a must-have for those who need it.
 
Level 1
Joined
Mar 24, 2019
Messages
2
The UI does not seem to totally stretch for me, @ ultrawide with 3440x1440 - is this someting of the fix file or is there just no more UI content? :)
 
Level 24
Joined
Jun 20, 2013
Messages
719
Hello i've to reinstall the client in 1.26 and downloaded this for the first time, but everytime i start the client, this message appear. I got the Visual C++ 64 that includes 2015,2017,2019 in one pack.

I want to know if someone else got the same error, or if the widescreen fix work and i just need to ignore the message. Or if need to install the x86 version.

Edit--

I got the Visual C++ x86 and the message doesn't appear anymore.
 

Attachments

  • RenderEdgeError.jpg
    RenderEdgeError.jpg
    26.8 KB · Views: 73
Last edited:
Top