[Solved] Removing selected/specific unit variables

Level 8
Joined
Jun 25, 2010
Messages
152
So, I've been updating a very old map of mine for the past year. The map itself is nearly 5 years old by this point and over the year I've vastly updated all its triggers to be efficient and leakless to the best of my ability.

However, I was a total noob those 5 years ago, and I foolishly did the 'Select Unit' option when tying events to a specific pre-placed unit instead of making use of variables or other more efficient means.

I was wondering it there is any way to remove these selected unit variables from the trigger editor, as they make the Trigger Editor itself lag by like 15-20 seconds everytime I do a 'unit' related trigger (unit-type only takes 5 seconds, but doing a single 'unit' related thing causes 15-20 seconds lag for the pop-up to appear). I believe it is due to the fact that there are so many of these variables.

And by selected/specific unit variables I mean stuff like this:
Dragon Slayer 01521
Town Hall 21410
Demon 004142

Those are just examples of what they look like.

Any solutions to removing those from the Trigger Editor?
 

Jampion

Code Reviewer
Level 15
Joined
Mar 25, 2016
Messages
1,328
You could delete the units and place them again.
Apart from that I don't know.
 
Level 24
Joined
Mar 15, 2012
Messages
2,780
So, I've been updating a very old map of mine for the past year. The map itself is nearly 5 years old by this point and over the year I've vastly updated all its triggers to be efficient and leakless to the best of my ability.

However, I was a total noob those 5 years ago, and I foolishly did the 'Select Unit' option when tying events to a specific pre-placed unit instead of making use of variables or other more efficient means.

I was wondering it there is any way to remove these selected unit variables from the trigger editor, as they make the Trigger Editor itself lag by like 15-20 seconds everytime I do a 'unit' related trigger (unit-type only takes 5 seconds, but doing a single 'unit' related thing causes 15-20 seconds lag for the pop-up to appear). I believe it is due to the fact that there are so many of these variables.

And by selected/specific unit variables I mean stuff like this:
Dragon Slayer 01521
Town Hall 21410
Demon 004142

Those are just examples of what they look like.

Any solutions to removing those from the Trigger Editor?
Could try using object manager, I am sure there is a way.
 

Jampion

Code Reviewer
Level 15
Joined
Mar 25, 2016
Messages
1,328
I think you can look under the units tab. Each unit will have an individual number. Units used by triggers have a plus symbol, where you can see the triggers. These are the unit variables you are looking for. Though the plus symbol is only there, if the unit is currently used by a trigger.
 
Level 11
Joined
Jun 2, 2004
Messages
849
Not a brush list issue; I did the same thing when I was a newbie and it lags the hell out of the GUI trigger editor every time it needs to load up unit variables.

Deleting and replacing is the only method I know for sure would work. Something that comes to mind is nuking the entirety of your trigger data and copy/pasting it back in.
 
Top