Problem w/ Weapon Sound

Level 6
Joined
Jul 2, 2008
Messages
156
SOLVED!!

Situation:
So I've got this unit that has a phoenix fire ability with the bristleback projectile to simulate machine gun fire. Naturally I want it to sound like a machine gun, so I take the desired sound effect and replace the internal sounds with it.

Problem:
The sound will not play when the weapon is fired unless I turn off 3d positional audio in the options menu. Is there any way to get the sound file to be compatible with the 3d positional? Or is there a way to turn off 3d positional audio for all players via the World Editor?
 
Last edited:
Level 27
Joined
Jan 26, 2007
Messages
4,788
I've never really checked the sounds, so I am not 100% sure this works, but did you change the Effect/Channel of the sound to "Combat"?
Perhaps that positions the sounds at the location of the attacked unit (so you will hear it when you're nearby that unit).

Otherwise, try to heigher the Distance Cutoff or something.
 
Level 6
Joined
Jul 2, 2008
Messages
156
Well then can you be more specific how to do so?
I've tried everything.

Maybe your thinking of sounds that don't replace internal files?
I should also point out that I'm not new to this and have been using worldedit for years and am aware of how to change the sounds properties when you click the "use sound" button and it adds it to the menu.

This doesn't change sounds that replace animations however.
 
Level 6
Joined
Jul 2, 2008
Messages
156
Okay I found the solution.
You were close with the channels, but the problem wasn't which channel, but how many channels.

I had to make my sound effect a 3d sound since I was replacing a 3d sound, so in order to do that I had to change the sound from stereo to mono (using a .wav editor program). After that, the sound worked flawlessly.

+Rep for at least pushing me off to the right direction.
 
Top