Dismiss Notice
60,000 passwords have been reset on July 8, 2019. If you cannot login, read this.

Portrait Model Vanishes when not talking

Discussion in 'Modeling & Animation' started by HerrDave, May 19, 2015.

  1. HerrDave

    HerrDave

    Joined:
    Dec 23, 2013
    Messages:
    1,095
    Resources:
    165
    Models:
    137
    Icons:
    20
    Skins:
    8
    Resources:
    165
    Greetings ladies and gentlemen, I have recently bumped into a problem so large it has its own parking and valet.

    During the re-animation of a model, I felt that not making a talk animation on this model would be rather silly-pocks, HOWEVER when I added both the new "portrait" and "portrait talk" this happened...

    As I was testing the model in the editor and in-game, I discovered that the "Portrait" animation either doesn't play, or makes the model vanish, or does something else entirely. The only time the model shows in the portrait window is when its talking.


    What could be the root problem of this?

    http://www.hiveworkshop.com/forums/pastebin.php?id=8pb4fl


    Extra Credit: What do you use to reduce the file-size of your BLPs?
     
  2. Tickles

    Tickles

    Joined:
    Aug 13, 2011
    Messages:
    671
    Resources:
    4
    Maps:
    4
    Resources:
    4
    So apparently there's a problem with the model's extents. In Magos, Edit > Calculate Extents should do the trick.

    And to reduce the size of BLPs, BLP Lab has the capability to reduce JPEG quality of BLP files (slightly lowering quality while drastically reducing file size).
     
  3. HerrDave

    HerrDave

    Joined:
    Dec 23, 2013
    Messages:
    1,095
    Resources:
    165
    Models:
    137
    Icons:
    20
    Skins:
    8
    Resources:
    165
    Thanks, that worked!