• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • 🏆 Hive's 6th HD Modeling Contest: Mechanical is now open! Design and model a mechanical creature, mechanized animal, a futuristic robotic being, or anything else your imagination can tinker with! 📅 Submissions close on June 30, 2024. Don't miss this opportunity to let your creativity shine! Enter now and show us your mechanical masterpiece! 🔗 Click here to enter!

Play sound under 'Unit Responses' channel?

Not open for further replies.
Level 10
May 31, 2019
Recently, I discovered a bug in my project where if the player has Unit Responses turned off in their settings, Zerg units will still play their 'ready' sound when they hatch, since they are 'hatched' via a function rather than trained like a normal unit.

So I thought maybe the issue was that the sounds played were in the wrong channel. All sounds used are defined in my modified UnitAckSounds.slk. I went about setting the channels to 2, 3, and 4 (all used by war3 unit response sounds in UnitAckSounds.slk), as well as setting the channel of the sound handles created in my jass script to the same values. This did not solve the issue.

I wonder if the Unit Responses setting is just hard-coded to only work with normal usage of unit acknowledgment sounds? Is there any way to get sounds played via JASS to respect the player's settings?
Not open for further replies.