• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • 🏆 Hive's 6th HD Modeling Contest: Mechanical is now open! Design and model a mechanical creature, mechanized animal, a futuristic robotic being, or anything else your imagination can tinker with! 📅 Submissions close on June 30, 2024. Don't miss this opportunity to let your creativity shine! Enter now and show us your mechanical masterpiece! 🔗 Click here to enter!

Jassnewgen Pack 5d problem

Status
Not open for further replies.
Level 3
Joined
Mar 15, 2015
Messages
53
So after a long time i discovered that i need Jassnewgen to import Vjass system/spell into my map, but i got some problem.
When i launch NewGen WE, it worked, but NewGen Warcraft didn't, it said "OnGameLoad.dll error could not hack game.dll. Please post logs/ongameload.txt"
so i heard that i have to switch W3 version to 1.21, it work but another problem appeared, i can't play my map in that version that usually i can in default version of my W3
I'm downloading the lastest patch (1.26) and will try to switch it to see whould it work or not.
Please help me :vw_death:
 
Level 3
Joined
Mar 15, 2015
Messages
53
There is no such thing as "newgen warcraft".

NewGen WE is just what it is: an upgraded editor. You launch your map in the unmodified WC3 installation.


I suppose you used the "test map" feature of Newgen? It's broken in 1.5d. Upgrade to Newgen 2.0 and the problem should be solved.

i see :ogre_haosis:
 

Dr Super Good

Spell Reviewer
Level 64
Joined
Jan 18, 2005
Messages
27,223
I suppose you used the "test map" feature of Newgen? It's broken in 1.5d. Upgrade to Newgen 2.0 and the problem should be solved.
Rubbish! I use 5d and can test perfectly. Well there is the "double save bug" but after saving twice it tests perfectly. Only broken thing is GUI hashtable handles not being available in the editor but who honestly cares about that.

The only problem is that the hack used by 5d only works for the 1.21 "worldedit.exe". As such you need to displace the latest "worldedit.exe" with the old one (keeping the latest version as a backup for patching later) which is also why GUI handles do not work. That and 5d comes with an obsolete JASSHelper version you must manually update and replace the native declaration file (the latest from Vexorian suffices and you can get the native declaration file from "War3Patch.mpq") as well as move some link file to recognize the new version but that is kind of trivial.

Make sure that any anti-virus software is not damaging JNGP when you install it. Many like Kaspersky will identify it as a virus due to the way it hooks up with the existing worldedit.exe and so damage it unless specifically added as an exclusion.
 
Rubbish! I use 5d and can test perfectly. Well there is the "double save bug" but after saving twice it tests perfectly. Only broken thing is GUI hashtable handles not being available in the editor but who honestly cares about that.

The only problem is that the hack used by 5d only works for the 1.21 "worldedit.exe". As such you need to displace the latest "worldedit.exe" with the old one (keeping the latest version as a backup for patching later) which is also why GUI handles do not work. That and 5d comes with an obsolete JASSHelper version you must manually update and replace the native declaration file (the latest from Vexorian suffices and you can get the native declaration file from "War3Patch.mpq") as well as move some link file to recognize the new version but that is kind of trivial.

Make sure that any anti-virus software is not damaging JNGP when you install it. Many like Kaspersky will identify it as a virus due to the way it hooks up with the existing worldedit.exe and so damage it unless specifically added as an exclusion.
... or he could just follow my advice and use the newest Newgen release so he doesn't have to deal with all this shit. Because why the fuck not? It's not like Newgen 1.5d offers any advantage over the new releases.
 
The "newest" release was not by the same people and as far as I know offers you nothing better than the 1.5d.
Let's see:
1) adds Sharpcraft support
2) comes with the newest Jasshelper pre-installed
3) Test map feature works without further tweaking
4) has a toggle for switching between Cohadars and Vexorians Jasshelper
5) comes with the newest TESH pre-installed

That's good enough for me to use the 2.x release.

And seriously, there is no reason NOT to use 2.x other than saving the time downloading it. It's not like anyone would ever miss Grimoire.
 
Level 3
Joined
Mar 15, 2015
Messages
53
Guys i'm back :p
Found out that i can't play (run) my map because it have something wrong with the jass trigger (in this i try to import Speed Past 522 system) disable all of the triggers then i can get in again.
So how exactly to import this system, i have zero exprerience atbout this...just run map in Newgen WE, import system by copy and paste and then done? or else
 
Level 11
Joined
Jun 2, 2013
Messages
613
Let's see:
1) adds Sharpcraft support
2) comes with the newest Jasshelper pre-installed
3) Test map feature works without further tweaking
4) has a toggle for switching between Cohadars and Vexorians Jasshelper
5) comes with the newest TESH pre-installed

That's good enough for me to use the 2.x release.

And seriously, there is no reason NOT to use 2.x other than saving the time downloading it. It's not like anyone would ever miss Grimoire.

6) Multiplayer emulation. Love that feature.
 
Status
Not open for further replies.
Top