• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • 🏆 Hive's 6th HD Modeling Contest: Mechanical is now open! Design and model a mechanical creature, mechanized animal, a futuristic robotic being, or anything else your imagination can tinker with! 📅 Submissions close on June 30, 2024. Don't miss this opportunity to let your creativity shine! Enter now and show us your mechanical masterpiece! 🔗 Click here to enter!

[Solved] Jasshelper crashes on detecting errors

Status
Not open for further replies.
Level 14
Joined
Apr 20, 2009
Messages
1,543
Hi all,

My jasshelper seems to crash JNGP v2.0 whenever it finds any errors in my code. Now to fix the errors I simply have to end the task in taskmanager and open the map, go to Jasshelper -> show previous errors. However this is very devious. I am using vexorian's jasshelper by checking it under Jasshelper in JNGP. I already tried overwriting the vexorianjasshelper executables with the ones from http://www.wc3c.net/showthread.php?t=88142
This doesn't seem to work. It's a pain in the ass to work like this. Is there anyone that knows why this happens? I would like to get this fixed quickly so I can move on to coding.
 
Last edited by a moderator:
Level 12
Joined
May 22, 2015
Messages
1,051
I feel your pain. I actually rage quit my editor and went to the default editor. It doesn't do code highlights and I can't look up functions, but I'm used to no highlighting and I just ctrl+f through http://jass.sourceforge.net/doc/api/Blizzard_j-source.shtml to find the functions I need.

It might not be what you want, but it might be better for now while you wait for a better answer. Hopefully this is useful to you.
 
Level 14
Joined
Apr 20, 2009
Messages
1,543
I can't go back to the regular editor, I code mainly in vjass which needs the compiler. And like I said, I can still fix my problems with a workaround but it's a total pain in the ass to close newgen whenever I have an error in my code.
 
Level 12
Joined
May 22, 2015
Messages
1,051
Ah okay. I haven't done anything that doesn't work in the default editor. All I can say then is good luck and try not to make errors haha.
 

Dr Super Good

Spell Reviewer
Level 64
Joined
Jan 18, 2005
Messages
27,229
What does the editor crash with (what error)? I do understand that Vexorian's last version probably does have a few fatal error bugs but these are so few and far between that I personally cannot recall any. Did this start recently or always been a problem with vJASS?
 
LambdaDelta had the same exact issue a few years ago. It might be worthwhile to send him a PM or VM and see if he ever got it working.

Which OS are you using? Did jasshelper work on your computer before? Does the crash happen with any map?

I don't remember anyone posting a solution to the issue, though. If all else fails, I recommend switching to Wurst rather than going to normal JASS. It'll be much easier to port your code, and iirc they have an extension language very similar to vJASS for that exact reason.
 
Level 14
Joined
Apr 20, 2009
Messages
1,543
I'm using Windows 7 64 bit Enterprise.
This is the first time installing jasshelper on my laptop.
The crash happens with any map.

There are no error codes. What happens is that jasshelper stops at the moment it says: Found errors, please wait... I have to stop the process with task manager in order to restart the editor, other then that the editor in it's entirety doesn't respond during jasshelper. It hasn't been a problem on my previous desktop computer when I was still using v5d. But now that I switched over to a laptop and am using v2.0 it's causing this issue.
I was using the exact same OS on my previous desktop computer b.t.w.

Is it possible to attach a debugger to the process in order to find out what's happening?
I'd rather stay with vjass then go over to wurst. If I can't find the issue I'd even rather go for the current workaround then going for wurst.

EDIT: It seems like the same thing happens if I try it with v5d instead of 2.0 but that's to be expected since it's the same jasshelper.
 

Dr Super Good

Spell Reviewer
Level 64
Joined
Jan 18, 2005
Messages
27,229
Could be anti-virus or permission based. Make sure the installation was not damaged by anti-virus and that the folder has been added to exclusions for virus scans (otherwise it will be damaged).

Try running it as an administrator. It could be that a lack of permissions causes it to break (eg accessing a file on C drive).
 
Level 14
Joined
Apr 20, 2009
Messages
1,543
I already have MSE setup so that it excludes my download directory and my JNGP folder. I've also already tried running as an administrator.
What exactly is gdb? Could you explain a little more perhaps?
 
Last edited:
Level 14
Joined
Apr 20, 2009
Messages
1,543
Go to the Jasshelper folder open both jasshelper and pjass and make sure there is no 'Open File - Security Warning' popup. If there is uncheck 'Always ask before opening this file'.

That fixed the problem entirely for me.

Thanks a lot! This solved my issue. To think it would be that simple... +rep!
 
Status
Not open for further replies.
Top