• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • 🏆 Hive's 6th HD Modeling Contest: Mechanical is now open! Design and model a mechanical creature, mechanized animal, a futuristic robotic being, or anything else your imagination can tinker with! 📅 Submissions close on June 30, 2024. Don't miss this opportunity to let your creativity shine! Enter now and show us your mechanical masterpiece! 🔗 Click here to enter!

Editor doesn't let me test map...

Status
Not open for further replies.
Level 20
Joined
Jul 14, 2011
Messages
3,213
Hi!

The_Witcher made a system for one of my maps. The thing is that I can test the file he sent me with the system added... But if I click anywhere on any of the jass codes (without changing anything) the map doesn't start. If i don't click on the code, but add anothe action to a trigger, the map doesn't start.

In order to enable the map testing I have to disable all of The_Witcher system triggers (3) and then the map works =/...

Tried opening the "Advanced Equipment System" made by The_Witcher. Test without touching, and everything goes fine. Clicked anywhere on the code, and again, unable to test. Game crashes (Not fatal error, just doesn't open the map, leaving me on the main wc3 screen)

I implemented long time ago the GDD Weep's system, and I never had problems with it. I opened the working map file, clicked on the GDD code, and map crashes. But worked after disabling Witcher's codes ¬¬...

BUT

I opened the SpellBar v.1.01 system made by dhk_undead_lord / aka Anachron, and clicked anywhere I wanted, and the map works, no matter how much I click, select, etc...

In order to "crash" it I disabled one of the triggers and then enabled it (A Window pop up sayin that a Init_Trig_.. bla bla.. had to be used". Then I was unable to test it xD... But i'm not planning to enable/disable triggers to crash the game, I was just testing how much I had to do to crash it xD.

I'm using JPNGv5d with last version of jasshelper and WC3 v 1.26a...
----------------------------------------------------------------------

This is really important for me. I've been stuck for over two weeks trying to implement systems but they keep crashing everytime i touch anything... I send the "unable to test" maps to Witcher, and he says it works fine, and i'm like o_O WTF...

-----------------------------

So.. I can test the maps Witcher sends me, but if i touch anything, can't test, even after saving -> Closing editor -> Open editor -> Open map -> test map...

X_X

EDIT:

JNPG Troubleshooting said:
When I use the test map button, Warcraft III will start but return to the main menu instead of loading a map?
This can happen when your map uses vJASS code and you hit the test map button when the map is unsaved (*-symbol is shown in the title bar) or the map has been saved-as directly before testing the map.
Simply save your map before every test-run, so that it's fully compiled.

I already tried that way... Come on, i just deleted an unit, saved, and done. Map crashed forever...

EDIT: Don't worry, it suddenly works now =/ xD
 
Last edited:
Status
Not open for further replies.
Top