Why isn't my map working??

Level 5
Joined
May 10, 2009
Messages
88
Ok, before I did the following events... (Using WEU imported JNG)

Before hand:
Conversion to roc worked.
Map openable.
Map hostable.

Events in between:
Imported custom AbilityData.slk
Added JASS function:
JASS:
Trigger - Take Peasent Defeat <gen> and remove the action (CustomDefeatBJ( Player(0), "TRIGSTR_700" ))
Added a bunch of other triggers, mainly CnP and redo for specific players,
nothing major, just normal editing.

Afterwords:
Map conversion successful.
Map not openable in WC3 bnet or single player.
Map not hostable (Map not found)

What did this? How can I fix it? A lot of people were waiting for the map i'm about to release, and it would've released yesterday if this hadn't happened.

Since then I have:
Tried using a new map to import w3x files into w3m and optimize.
exporting and deleting AbilityData.slk.

Nothing worked, any ideas?
 
Level 16
Joined
Aug 19, 2007
Messages
1,381
Map not openable in WC3 bnet or single player.
, hasn't this got something to do that your map got corrupt (broken)? If you have a backup of it, try moving some of the corrupt/broken inner map files to the backup map (make sure you have another backup somewhere) through a mpq editor and see where it goes wrong.

Or maybe just save the map and test it in the editor. Or maybe try JassnewgenPack editor.
 
Top