• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • 🏆 Hive's 6th HD Modeling Contest: Mechanical is now open! Design and model a mechanical creature, mechanized animal, a futuristic robotic being, or anything else your imagination can tinker with! 📅 Submissions close on June 30, 2024. Don't miss this opportunity to let your creativity shine! Enter now and show us your mechanical masterpiece! 🔗 Click here to enter!

Spell Disabled Icon Problem

Status
Not open for further replies.
Level 11
Joined
Feb 14, 2009
Messages
884
I have created a custom ability (based on blink) and I use an imported icon. The problem is that I get the notorious green icon of death when that ability is disabled. I tried to import an icon to be used in the ''Art-Icon-Turn Off'' with no luck. What I found out was that the Blink spell uses ONE icon for Research, Normal, Turn Off etc. Is there any way I can fix that (for example, combining all the icons in one model, and use it in the same fashion blink does)?

{EDIT}
...forgot to mention, I have the same problem with item icons (Icons don't have a 'turned off' icon anyway).
 
Last edited by a moderator:
Level 11
Joined
Feb 14, 2009
Messages
884
Yes, I have done but it doesn't work! That's the point. Blink uses ONE icon pack for everything, so the 'Turned Off' value isn't used.
 
Level 11
Joined
Feb 14, 2009
Messages
884
You are right, I had imported both icons using a 'ReplaceableTextures\CommandButtons\BTNExample.blp' format. I changed the disabled button's path and it works now. Thanks a lot.
 
Status
Not open for further replies.
Top