• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • 🏆 Hive's 6th HD Modeling Contest: Mechanical is now open! Design and model a mechanical creature, mechanized animal, a futuristic robotic being, or anything else your imagination can tinker with! 📅 Submissions close on June 30, 2024. Don't miss this opportunity to let your creativity shine! Enter now and show us your mechanical masterpiece! 🔗 Click here to enter!

[Spell] Custom Icon vs. Disabled

Status
Not open for further replies.
Level 2
Joined
Mar 10, 2014
Messages
8
I have an ability that has a tech requirement. It has a custom icon. Before being researched, it comes up as the green square like it has no icon on the unit with that ability.

I have the disabled icon image file imported (with the DIS before the regular name), but can't figure out where to put it. I checked out a ton of tech required abilities from melee, and checked in advanced > gameplay interface...

Also this happens with other abilities with custom icons when you hit a menu button.

Thanks in advance!
 
Level 26
Joined
Sep 26, 2009
Messages
2,427
It's about the path to these icons.
"active" icons have to have path: "ReplaceableTextures\CommandButtons\<name>.blp"
"disabled" icons have to have path: "ReplaceableTextures\CommandButtonsDisabled\<name>.blp"

Most of the time, icon names also contain the BTN (active) and DISBTN (disabled) prefixes.
 
Level 2
Joined
Mar 10, 2014
Messages
8
I renamed my custom icon files, and carefully imported them, changing paths.

I now have

ReplaceableTextures\CommandButtons\ArcaniteShield.blp

and

ReplaceableTextures\CommandButtonsDisabled\ArcaniteShield.blp

but icon still shows up as green square when disabled or menu open.


Is there anywhere in the WO I can set what the disabled icon should be?
 
Last edited:
Level 2
Joined
Mar 10, 2014
Messages
8
Ohhhh

Sorry, I get it now. I thought the disabled button and the regular one had to have exact same file name, diff path... it works fine with the BTN DISBTN before file name.... thanks for the help, Nichilus!!
 
Status
Not open for further replies.
Top