1. Updated Resource Submission Rules: All model & skin resource submissions must now include an in-game screenshot. This is to help speed up the moderation process and to show how the model and/or texture looks like from the in-game camera.
    Dismiss Notice
  2. DID YOU KNOW - That you can unlock new rank icons by posting on the forums or winning contests? Click here to customize your rank or read our User Rank Policy to see a list of ranks that you can unlock. Have you won a contest and still havn't received your rank award? Then please contact the administration.
    Dismiss Notice
  3. The Lich King demands your service! We've reached the 19th edition of the Icon Contest. Come along and make some chilling servants for the one true king.
    Dismiss Notice
  4. The 4th SFX Contest has started. Be sure to participate and have a fun factor in it.
    Dismiss Notice
  5. The poll for the 21st Terraining Contest is LIVE. Be sure to check out the entries and vote for one.
    Dismiss Notice
  6. The results are out! Check them out.
    Dismiss Notice
  7. Don’t forget to sign up for the Hive Cup. There’s a 555 EUR prize pool. Sign up now!
    Dismiss Notice
  8. The Hive Workshop Cup contest results have been announced! See the maps that'll be featured in the Hive Workshop Cup tournament!
    Dismiss Notice
  9. Check out the Staff job openings thread.
    Dismiss Notice
Dismiss Notice
60,000 passwords have been reset on July 8, 2019. If you cannot login, read this.

[Trigger] Special Effect Won't Go Away

Discussion in 'Triggers & Scripts' started by Pson, Apr 29, 2013.

  1. Pson

    Pson

    Joined:
    Apr 5, 2013
    Messages:
    236
    Resources:
    0
    Resources:
    0
    Thanks a lot:) And thanks to everyone else who tried to help as well)
     
  2. Pson

    Pson

    Joined:
    Apr 5, 2013
    Messages:
    236
    Resources:
    0
    Resources:
    0
    There's still some issue now that I tested it.

    Custom script: Set udg_SFX = null
    Custom script: Set udg_Building = null

    Appear as errors (expected endif) when I try to save.

    When I disable them and try the trigger, the building model hides upon finishing construction. Are they responsible for it?
     
  3. Maker

    Maker

    Joined:
    Mar 6, 2006
    Messages:
    9,181
    Resources:
    17
    Maps:
    2
    Spells:
    14
    Tutorials:
    1
    Resources:
    17
    Small s in set.
     
  4. Pson

    Pson

    Joined:
    Apr 5, 2013
    Messages:
    236
    Resources:
    0
    Resources:
    0
    Cheers, that is fixed:) Still the building model remains invisible upon construction though.
     
  5. Zwiebelchen

    Zwiebelchen

    Joined:
    Sep 17, 2009
    Messages:
    6,789
    Resources:
    12
    Models:
    5
    Maps:
    1
    Spells:
    1
    Tutorials:
    1
    JASS:
    4
    Resources:
    12
    Does your model used for the building have the attachment point "origin"?
    Better create that SFX at coordinates, not attached to the building.
     
  6. Pson

    Pson

    Joined:
    Apr 5, 2013
    Messages:
    236
    Resources:
    0
    Resources:
    0
    Since the trigger seems correct, shouldn't there be another way around it? If not, would I need some custom script to work with the coordinates/avoid leaks? Also could it have issues like needing an extra trigger for effect destruction?
     
  7. deathismyfriend

    deathismyfriend

    Joined:
    Oct 24, 2012
    Messages:
    6,529
    Resources:
    14
    Spells:
    12
    Tutorials:
    2
    Resources:
    14
    destruction is the same. u just create it at position of unit rather than attached to unit. also u need to clear the point leak when u do it this way.
     
  8. Pson

    Pson

    Joined:
    Apr 5, 2013
    Messages:
    236
    Resources:
    0
    Resources:
    0
    And how do I clear the point leak please?

    Edit:Actually i think it has something to do with the transparency. Setting it to 100% first/0% after construction, makes the building as well as the effect invisible until construction is done. Setting the opposite, makes both the building and the effect visible during construction and hides both of them after it's done.
     
  9. deathismyfriend

    deathismyfriend

    Joined:
    Oct 24, 2012
    Messages:
    6,529
    Resources:
    14
    Spells:
    12
    Tutorials:
    2
    Resources:
    14
  10. Pson

    Pson

    Joined:
    Apr 5, 2013
    Messages:
    236
    Resources:
    0
    Resources:
    0
    1) Thanks:) It's the Custom script: call RemoveLocation(udg_loc) right?
    2) I've merged them already as soon as I remembered that:)
    3) What happens according to my tests is:
    -Invisible building through transparency change = Invisible Effect
    -Visible building through transparency change = Visible Effect
     
  11. deathismyfriend

    deathismyfriend

    Joined:
    Oct 24, 2012
    Messages:
    6,529
    Resources:
    14
    Spells:
    12
    Tutorials:
    2
    Resources:
    14
    1) u need to chnage the udg_loc to ur point variable.
    2) not sure what u mean by that...
    3) if that happens then create the effect at point instead of on the unit.