1. Icon Contest #17 - Poll is up! Vote for the most legendary icon set!
    Dismiss Notice
  2. Choose your favourite retro song at the Music Contest #10 - Poll!
    Dismiss Notice
  3. Join us in our custom games night on Saturday, July 28. If you'd like to create a map for the night, check out the map challenge!
    Dismiss Notice
  4. The results for Texturing Contest #28 are out! Step by to congratulate our winners!
    Dismiss Notice
  5. We've created the Staff Job Openings thread. We're currently in need of icon, video production, and social/multimedia positions to be filled. Thank you!
    Dismiss Notice
  6. Music Contest #10 Retro is out! Join us for some retro/vintage fun!
    Dismiss Notice
  7. Don't be stagnant - embrace change! The time has come to evolve and join the Techtree Contest #12 - Evolution.
    Dismiss Notice
  8. On May 20th a new law about privacy and data processing comes into work in the EU. I am no lawyer and I need help figuring out if we comply and if not, what we must do about it. Please message me if you can provide any assistance. Read more. Ralle
    Dismiss Notice

Solving "Fatal Error" Problems in WC3

Discussion in '"Graveyard"' started by Shadow_Fox, Jan 8, 2008.

  1. Shadow_Fox

    Shadow_Fox

    Joined:
    Sep 1, 2006
    Messages:
    461
    Resources:
    18
    Maps:
    18
    Resources:
    18
    When playing Warcraft, most people will eventually encounter a "fatal error" these errors are of course, unavoidable, but there is a way to minimize their frequency! Here's how:

    Step 1:
    •Go to the shortcut you run Warcraft III from(Usually on your desktop labeled
    "Warcraft III: Reign of Chaos", or "Warcraft III: The frozen Throne", or make a new one.

    Step 2:
    •Right click the shortcut and click "properties" and in the "Target" box, add -opengl to the end
    It should now look something like this: "C:\Program Files\Warcraft III\Frozen Throne.exe" -opengl or wherever your shortcut is linked to.

    You're done!
    Warcraft III should now fatal error considerably less, keep in mind this alters Warcraft's graphics and performance slightly. Also keep in mind you will still have fatal errors, but thanks to this method, they should occur VERY rarely if never.

    Comments:

    This is basicly like ralle's "playing warcraft in a window" tutorial, but instead of -window, you add -opengl, for a totally different effect, it's short, but i hope it helps some people who have problems with fatal errors! (like me).
     
  2. Eleandor

    Eleandor

    Joined:
    Aug 21, 2005
    Messages:
    3,682
    Resources:
    2
    Models:
    1
    Tutorials:
    1
    Resources:
    2
    Shouldn't your videocard support opengl then?

    Anyway, I have gotten a fatal error only once, so it's not really anything I need to do...
     
  3. Earth-Fury

    Earth-Fury

    Joined:
    Feb 18, 2004
    Messages:
    538
    Resources:
    1
    Tutorials:
    1
    Resources:
    1
    most fatal errors in WC3 custom maps are caused by the map, not by the game.

    As for fatal errors not caused by the map, they are few and far between within Warcraft 3. If switching to the OpenGL rendering engine fixes a fatal error for you, then you should consider upgrading your graphics card's drivers. A crash when running soley under DirectX in WC3 is likely just a symptom of a larger issue, so simply switching to OpenGL is likely not the most prudent course of action.

    Also, why not post a general command line switches tutorial, including all the command line switched WC3 uses? That would be far more of actual utility to many people.
     
  4. AJalex

    AJalex

    Joined:
    Nov 13, 2006
    Messages:
    248
    Resources:
    1
    Tutorials:
    1
    Resources:
    1
    hmm as i know all VCards need to support opengl .... almost all games have opengl modes .... and well if it's a profesional gaming card it supports higher opengl standards etc.
     
  5. Dr Super Good

    Dr Super Good

    Spell Reviewer

    Joined:
    Jan 18, 2005
    Messages:
    24,460
    Resources:
    3
    Maps:
    1
    Spells:
    2
    Resources:
    3
    This sounds like a lie as -opengl runs WC3 in slower, less efficent openGL mode which can cause graphical errors (some people using openGL say the map SWAT aftermath crashes under some conditions now fixed) and disable you from applying your extra graphic enhancers from your driver (like AA or AF).

    This may work for vista thou as then it ignores the DX9 emulator and uses openGL which is not emulated. However I use XP and DX9 and WC3 hardly ever crashes.

    Also this does not work for users of MACS as they by default use openGL.
     
  6. Vicboy

    Vicboy

    Joined:
    Aug 20, 2007
    Messages:
    1,045
    Resources:
    2
    Maps:
    2
    Resources:
    2
    Omg, tell me what to do to fix it... I'm having the same problem! It wont run for some without openGL!!!
     
  7. Dr Super Good

    Dr Super Good

    Spell Reviewer

    Joined:
    Jan 18, 2005
    Messages:
    24,460
    Resources:
    3
    Maps:
    1
    Spells:
    2
    Resources:
    3
    DirectX mode is for microsoft windows only. So if your using it on linux or a mac, openGL is the only thing you can use.

    However if your using XP and this is happening you have a major problem. To fix try reinstalling DirectX, warcraft 3 ROC + TFT and your graphic drivers as those all are linked to direct X.

    If it still persists, make sure your card supports direct X properly as some ATI cards give trouble when using direct X.
     
  8. Kaitech[SanD]

    Kaitech[SanD]

    Joined:
    Apr 11, 2007
    Messages:
    1,928
    Resources:
    0
    Resources:
    0
    Sorry for the necropost but does this solve them freaking annoying Access Violations?