• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • 🏆 Hive's 6th HD Modeling Contest: Mechanical is now open! Design and model a mechanical creature, mechanized animal, a futuristic robotic being, or anything else your imagination can tinker with! 📅 Submissions close on June 30, 2024. Don't miss this opportunity to let your creativity shine! Enter now and show us your mechanical masterpiece! 🔗 Click here to enter!

MilkShape to Warcraft III

Status
Not open for further replies.
Level 18
Joined
Aug 23, 2008
Messages
2,319
I've been working a bit on a model in MilkShape, but it seems that the new version of MilkShape doesn't include an exported to Warcraft III .MDL files. To get this anyway, I downloaded the Warcraft III Import/Export.DLL files to allow MilkShape to export the MS3D files to MDL files. However, when I try to do so, MilkShape gives me an error that the original model isn't found, so it doesn't export. The model was started by me in MilkShape, so that's not the problem. I did read that the DLL file doesn't support certain MilkShape features like Add Group. I've made 1 group and set faces in it, so I think this is preventing the export process. If anybody can tell me how to remove these vertexes/faces from group (not delete them, just seperate from the group), so I can delete the group without deleting the vetexes/faces, it might solve my problem and allow me to export to Warcraft III MDL. +rep is in place ofcourse :wink:


EDIT: I've just tried to make a new 'model' with a few vertexes and export it, but even then I get the same error! What's wrong with this thing?

EDIT 2: I've got help on the chat. To go from MS3D to MDX, I had to use magos. However, the MDX does have a file size, but when I want to check it in magos or Wc3 Viewer, I get an empty field. My model isn't anywhere to be seen there :S
Anyone knows how comes or got a solution for this?
 
Last edited:
Status
Not open for further replies.
Top