Some notes:
Dark Helper:
Create a config trigger, which should include:
- | Variable for DummyUnit |
- Nope.
- | Variable for the spell's duration |
- Easy enough to change so nope.
- | Variable for the Special Effect |
- Yet again there is no point.
| |
-
Set TempUnit = (Triggering unit)
-
Set TempPlayer = (Owner of TempUnit)
-
Set TempPoint2 = (Position of TempUnit)
-->
-
Set TempPlayer = (Triggering Player)
-
Set TempPoint2 = (Position of (Triggering unit))
-
Unit - Add a 5.00 second Generic expiration timer to (Last created unit)
-
Unit - Order (Last created unit) to Move To TempPoint
^Use the temp unit variable to gain performance.
Why do you nulling "TempUnit"? In next cast it gets a new value again.
There is never a need to null players, doesn't matter they are global or local. They are constant and never get destroyed/removed.
Null the local effect in and of trigger.
I feel better nulling players and it feels more proper.
Change the variable and object data names for an easy identification towards the spell: prefix_Name
Shadow Move:
-
Set TS_Shadow_Move_TPL[TS_shadowindex] = (Owner of TS_Shadow_Move_TUOABC[TS_shadowindex])
-->
Set TS_Shadow_Move_TPL[TS_shadowindex] = (Triggering Player))
The ITE where you check to turn off the loop trigger should be moved into the deindex part.
Kay.
"Invulnerable (Neutral)" should be binded to the spell custom spells, as it can cause bugs since the user also might add this ability to any unit without using this system.
I don't get what you meant by this and it should never bug.
-
(Random integer number between 1 and 2) Equal to 1
^You can replace this by a boolean[index] which you always change between true/false to gain performance.
If true you create a special effect and set it "false". Else you just set it "true".
Nope, that would be rather useless creating an extra variable....
AttackType and DamageType should be configurable.
Probably...
Other units may block the caster, so it will never reach the targeted unit. Fix this, please.
Just did, have to upload new version though still.
So variable names should be improved. A name should say something about the intention of the variable.
For example, I would never know what following variables should represent, if I would not see the input:
-
Set TS_Shadow_Move_CU
-
Set TS_Shadow_Move_TUOABC
-
Set TS_Shadow_Move_TPL
There might be some more points, but this should be enough for next update.