• 💀 Happy Halloween! 💀 It's time to vote for the best terrain! Check out the entries to Hive's HD Terrain Contest #2 - Vampire Folklore.❗️Poll closes on November 14, 2023. 🔗Click here to cast your vote!
  • 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • 🏆 HD Level Design Contest #1 is OPEN! Contestants must create a maze with at least one entry point, and at least one exit point. The map should be made in HD mode, and should not be openable in SD. Only custom models from Hive's HD model and texture sections are allowed. The only exceptions are DNC models and omnilights. This is mainly a visual and design oriented contest, not technical. The UI and video walkthrough rules are there to give everyone an equal shot at victory by standardizing how viewers see the terrain. 🔗Click here to enter!

Can no longer open my map!

Not open for further replies.
Since the utter trainwreck of patch 1.33, I can no longer open my map in the world editor. I have tried to edit the map with the MPQ editor and looked at different threads here at Hive, to no avail.

Here is an older vversion of the map to download : https://drive.google.com/file/d/1H4o5wqvTAdbjgKtzR0RzL15cO1e1GHEM/view?usp=share_link

Anyone able to open it or does it crash for you as well?
Can anyone please help a desperate soul? Thanks in advance for any help!
Hello Malmgrev,

I was able to open this map on, but then on the same computer when I would launch the World Editor also, the World Editor would crash when attempting to open this map.

I heard from @Kam a while ago that Patch 1.33 was preventing his map from opening because he had a Terrain Tile overridden with Asset Manager. So, I do not fully understand the programming flaw behind it, but something on 1.33 does not like custom textures or maybe custom texture overrides in some cases. When I used an MPQ editor and blanket deleted the "Units\", "Buildings\" and "Doodads\" folders in your map, as well as all textures at the base path ("no path" in asset manager) then after I did this the map would open on the Patch 1.33 World Editor. However, I did not have the attention span to determine if deleting all of these is necessary, or if some of them can be kept. I tried deleting the folders but not the "no path" textures, and I tried deleting the "no path" textures but not the folders, but as far as I could tell in both those cases it still would not open. So you may simply need to remove all of it, and given how many there are I am assuming this would detract from your custom mapping experience.

Based on rumors I have heard about the state of Reforged at Blizzard, I think that it is safe to assume this bug in the World Editor will not be fixed any time soon. So, I was going to suggest you could obtain a copy of Patch 1.32 and use that World Editor to make maps, even if you are going to play the maps on Patch 1.33. But, thinking about this, I decided to also try playing your map on Patch 1.33. (When I tried to do that, my Patch 1.33 updated so now I have Patch rather than that I tested your map in World Editor with. I assume they are not different on these issues, as the goal of Patch 1.33 was to add a Ranked Ladder and so its developer would not have been focused on custom game compatibility.)

I am not certain if you already tried this, but here is what I am seeing visually (on the same computer this morning):

Patch 1.33:

Patch 1.32:

So it seems like your custom character art is having some kind of problem even in-game, and not just in the World Editor.
You may need to review the exact DDS format used for Warcraft III: Reforged Patch 1.33 textures and update your custom textures to use the exact DDS format of the Patch 1.33 -- maybe the Patch 1.33 is more specific and requires a more specific texture compression algorithm. I am not certain. Maybe you can do some tests.

But, in summary, the safe assumption is that Blizzard is not going to fix this, so if you want to continue you need to find a workaround. That might be Patch 1.32 World Editor and a new texture format, or it might be HiveWE built from source with Reforged graphics mode, or something else.
Last edited:
Level 9
Oct 10, 2020
I was literally making a melee map with just imported models. Just a simple altered melee map with custom races and as I worked on the map little by little I tested map after each unit was properly imported and all worked great in game. I wake up this morning to continue the map and it won't even load it automatically crashes. I even just tried opening directly from the WC3/Map/Downloads folder and same thing. Very disappointed that I can't even make a map anymore even when the models worked fine in game when tested.
Not open for further replies.