1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Participate in Blizzard's Public Test Realm to give them feedback on the upcoming patches. Info is here.
    Dismiss Notice
  3. Take part in forum poll and decide the winner of Icon Contest #16!
    Dismiss Notice
  4. Congratulate the winners of the first ATC contest!
    Dismiss Notice
  5. Zwiebelchen is hosting a special UI texturing contest. Whomever wins will get a $150 reward through paypal! Come along and draw your texturing tools for the Fantastic Adventurer UI contest.
    Dismiss Notice
  6. Sneak, pickpocket and assassinate! Create a stealth map in Mini-Mapping Contest #14!
    Dismiss Notice
  7. Music Contest #8 - Hive Soundtrack is up! Create the soundtrack for the upcoming videos of Hive Workshop's YouTube Channel.
    Dismiss Notice

Allow Local Files not working on Windows7

Discussion in 'World Editor Help Zone' started by kalipou134, Feb 17, 2014.

  1. kalipou134

    kalipou134

    Joined:
    Apr 1, 2012
    Messages:
    8
    Resources:
    0
    Resources:
    0
    I got a laptop with Win7 that I'm trying to allow local files on and I can't seem to make it work with the usual method.

    Here's what I did so far:

    Open regedit>HKEY_CURRENT_USER>Software>Blizz>Wc3> NewDWORD "Allow Local Files" Value 1


    Yet its not working, the game loads the MPQs and gnores local file paths. I know the paths and files work because I have the same setting on my Vista Desktop and have no problem there.

    So I'm guessing something's wrong with the way I enabled in the registry. On Vista its usually regedit>HKEY_Local Machine> Software>etc but on Win7 theres no Blizz folder under there...

    Anyone has any insight?
     
  2. Dr Super Good

    Dr Super Good

    Joined:
    Jan 18, 2005
    Messages:
    23,322
    Resources:
    3
    Maps:
    1
    Spells:
    2
    Resources:
    3
    Warcraft III does not use that registry path. It uses...
    Unless you get the path exactly as Warcraft III is expecting it will fail to work correctly. Make sure you are browsing the HKEY_CURRENT_USER registry and not some of the other ones. Alternatively it might vary depending on how the installation was performed (install for all users?) so it could be under a different user registry such as local machine. If there really is no registry for WC3 then your installation must have bugged and a reinstall is recommended. Do remember to run regedit as an administrator.