Workers returning to new town hall

Level 5
Joined
Jun 13, 2015
Messages
129
I am trying to experiment with long-range mining whereby:
-workers walk a longer distance to the gold mine
-workers return the gold to the nearest town hall structure

However, it would seem that although this seems to work, once I build a new town hall further in distance(and displacement), workers will return gold to that town hall instead, despite having to travel a longer distance. Help/advice would be very much appreciated!
 
Level 28
Joined
Feb 27, 2007
Messages
4,106
If you are using a trigger to achieve this you'll need to post the trigger here. If no trigger is involved you're saying that workers automatically return to the newest constructed town hall? That seems bonkers because then building an expansion in a melee game would make your main workers switch to returning at the expansion... which doesn't happen.
 
Level 5
Joined
Jun 13, 2015
Messages
129
If you are using a trigger to achieve this you'll need to post the trigger here. If no trigger is involved you're saying that workers automatically return to the newest constructed town hall? That seems bonkers because then building an expansion in a melee game would make your main workers switch to returning at the expansion... which doesn't happen.

Nope not using any triggers, this only happens when I have workers mining from a town hall far away then I build another new town hall further somewhere. I am using an old version of WC3 if it helps...
 
Level 28
Joined
Feb 27, 2007
Messages
4,106
I was able to replicate them switching from TH1 to a new TH2 built closer to the gold mine automatically. I was not able to replicate them switching to another new TH3 that's further away than the one TH2 they're returning to. In fact even if I order peasants carrying gold to return their resources to TH3 they would then switch back to TH2 after leaving the gold mine again. I'm on 1.29.

Can you post the map in which you do get this behavior? You can try with my test map too, attached.
 

Attachments

  • Test Fixed.w3x
    18.7 KB · Views: 36
Level 5
Joined
Jun 13, 2015
Messages
129
I was able to replicate them switching from TH1 to a new TH2 built closer to the gold mine automatically. I was not able to replicate them switching to another new TH3 that's further away than the one TH2 they're returning to. In fact even if I order peasants carrying gold to return their resources to TH3 they would then switch back to TH2 after leaving the gold mine again. I'm on 1.29.

Can you post the map in which you do get this behavior? You can try with my test map too, attached.

I see thanks for your effort!
Here's the map below, just build the TH at the gold mine(only one other gold mine)
 

Attachments

  • Raiders2.w3x
    154.3 KB · Views: 38
Level 5
Joined
Jun 13, 2015
Messages
129
After playing around on your test map, I may have a theory regarding this problem.
My rough idea is that maybe peasants will be split between 2 THs if one is overfilled. I let the peasants mine from the middle gold mine and afterwards, built a TH below the mid gold mine, further in displacement than the first TH.
Results: Some of the peasants did return gold to the new town hall, but not all of them.
 
Level 28
Joined
Feb 27, 2007
Messages
4,106
Okay I dug and I found the problem: it's 100% something to do with how your special mountain pass gold mine is configured. If you replace it with your other custom gold mine the problem goes away. Also peons harvesting lumber from a tree in the base don't change their resource drop-off point (I deleted the lumber mill to test them returning to the Orchold like gold) when you build a new Battle Hall, further confirming it's not an automatic AI behavior. As for what specifically is wrong, I really have no idea; I looked through to compare the stats of both your gold mines and nothing jumped out as me as being the reason. I would guess it's simply because you didn't base it on a regular gold mine unit.

Make a copy of your other gold mine unit and then change its appearance to the circle of power and all the other stuff. It should work properly and not siphon peons off then.
 
Level 5
Joined
Jun 13, 2015
Messages
129
Okay I dug and I found the problem: it's 100% something to do with how your special mountain pass gold mine is configured. If you replace it with your other custom gold mine the problem goes away. Also peons harvesting lumber from a tree in the base don't change their resource drop-off point (I deleted the lumber mill to test them returning to the Orchold like gold) when you build a new Battle Hall, further confirming it's not an automatic AI behavior. As for what specifically is wrong, I really have no idea; I looked through to compare the stats of both your gold mines and nothing jumped out as me as being the reason. I would guess it's simply because you didn't base it on a regular gold mine unit.

Make a copy of your other gold mine unit and then change its appearance to the circle of power and all the other stuff. It should work properly and not siphon peons off then.

I see, so I basically need to copy the Neutral Passive gold mine building if I am reading this right, and my problems should be solved. I will try out your suggestion when I am free and tell you the results. Really thanks a lot man!
I actually have a similar problem on another (sadly abandoned) map, but I might go back to it now I have a possible solution.
 
Level 5
Joined
Jun 13, 2015
Messages
129
I tried a couple of times without success.
First attempt: I copied my other gold mine and changed only the name and art. Once the new TH is built, the peon return gold straight to the new TH, as though the Orchold wasn't there
Second attempt: I created a new unit based on the melee Gold Mine, changing only pathing to Circle of Power(Medium), name and it's art. Results are the same as my first attempt... :(

Main problem is peons just ignore the old TH when new TH is built, and returns resources back to the new TH. Maybe pathing of the "circle of power gold mine" should not be changed?
I have included the updated map with my attempts there vvv
 

Attachments

  • Raiders2.w3x
    181.2 KB · Views: 35
Level 28
Joined
Feb 27, 2007
Messages
4,106
Maybe it's a patch-specific issue, then. I am on 1.29 and when I put a copy of your other custom gold mine (the one in the middle of the map) where your mountain pass gold mine is, they no longer switched to the new town hall when another Battle Hall was built.
 
Level 28
Joined
Feb 27, 2007
Messages
4,106
Huh okay so I tested more and I was wrong before. It's not the unit itself but some sort of pathing error, probably with how you've set up the pathing blockers. I click-dragged the Shimmer Valley Pass down so that it is more in the actual town area, then deleted the lumber mill and tested again. The problem was no longer present (so either pathing issue or it's because I'm on 1.29). I moved the mine back and the problem reappeared (in my previous message I was checking with the gold mine within the city limits). Check the attached map to see if it's working properly for you (it should be).
 

Attachments

  • Raiders2 (1).w3x
    180.7 KB · Views: 42
Level 5
Joined
Jun 13, 2015
Messages
129
I tested it out and yes(finally!), the bug does not occur anymore(to think the solution was so simple), I guess it has something to do with pathing after all. I would like to give you more rep but idk whether that's too much rep per forum or what.
I guess i'll look into another map I have which has a similar issue. Once again thank you! :)
 
Top