• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • 🏆 Hive's 6th HD Modeling Contest: Mechanical is now open! Design and model a mechanical creature, mechanized animal, a futuristic robotic being, or anything else your imagination can tinker with! 📅 Submissions close on June 30, 2024. Don't miss this opportunity to let your creativity shine! Enter now and show us your mechanical masterpiece! 🔗 Click here to enter!

Weird special effect behaviour change overnight

Not open for further replies.
Level 5
Jul 31, 2020

So, this is sort of a weird one because I technically solved the issue already, I'm just trying to wrap my head around what's going on. We have these effects that have "no animations" or rather they have one single animation they play once. Real example is Thunder Clap; it claps once, done.

To my best knowledge there was no patch or anything. I seem to have lost the ability to quick-n-dirty spawn this type of effect to play their single animation once using either AddSpecialEffect or AddSpecialEffectLoc. Keep in mind that I did go through my options, so I checked AddSpecialEffectTarget as well, and somehow that one seems unchanged. What happened till now was: I spawned the effect to some coordinates, it defaulted to playing its animation once, destroyed it, done. What happens now with the first two natives is: nothing. The effect spawns, but it defaults to no animation. I "solved it" by calling BlzSetSpecialEffectTime to set them to zero, but the point is that I didn't have to do this till today.

I first noticed it while making a new ability as I was losing my mind since I couldn't for the life of me spawn the effect the same way I've been doing it for years. Then I checked out something older to see if the issue surfaced elsewhere too, and it did. It seems retroactive. That's not all, I loaded up a very basic test map I made yesterday night, launched it without changing anything at all or saving, and it doesn't work either. Something that worked less than 24 hours ago. I also created a brand new map and just tried spawning some effects, that's when I tried setting their time to zero to make them play.

Anyone experienced this before? Am I actually supposed to go back to every instance where I used this technique just to add BlzSetSpecialEffectTime? I'm really not sure how it could break with no patch or map/script changes. If anyone has any idea what I could have accidentally changed to do this (since I haven't the slightest clue at the moment), I'm all ears.
Not open for further replies.