Dismiss Notice
60,000 passwords have been reset on July 8, 2019. If you cannot login, read this.

Unit based on Orc Grunt is making annoying casting noises

Discussion in 'World Editor Help Zone' started by Teelo, Apr 30, 2009.

  1. Teelo

    Teelo

    Joined:
    Mar 31, 2009
    Messages:
    709
    Resources:
    1
    Maps:
    1
    Resources:
    1
    I've based a unit on the Orc Grunt, and given it three abilities based off Channel, and one based off Frenzy.
    Whenever my unit casts any of these four abilities, it makes a sort of... shouting noise. None of the other units (from my testing) have done this, so whats up with the Orc Grunt?
     
  2. Just_Spectating

    Just_Spectating

    Joined:
    May 16, 2007
    Messages:
    7,022
    Resources:
    46
    Models:
    11
    Icons:
    9
    Skins:
    26
    Resources:
    46
    probably a sound that is attached with the spell animation because it is mainly only used for the Upgrade.

    Just like how the rifleman's attack animation has the sound attached to it.
     
  3. Teelo

    Teelo

    Joined:
    Mar 31, 2009
    Messages:
    709
    Resources:
    1
    Maps:
    1
    Resources:
    1
    Only the spell based off Frenzy has an animation attached to it, and the sound played is supposed to be Defend.
    The other three based off Channel are completely handled by the triggers, and aside from one of them playing the units melee swing, shouldn't be showing any animations or playing any sounds at all!
    I should mention that I've given the same abilities to various units, and it only seems to be the Orc Grunt thats doing this when it uses the very same ability.

    Edit: On a similiar note, I've based an ability off Death Coil, made it only castable on enemies, and changed the animation to fireball.
    The damned thing is still showing the deathcoil animation on the target, even though I removed that animation!
    I first tried basing the spell off Fireball, but it seemed to cause a permanant stun effect, and I couldn't figure out a way to remove that either.
     
    Last edited: Apr 30, 2009
  4. Teelo

    Teelo

    Joined:
    Mar 31, 2009
    Messages:
    709
    Resources:
    1
    Maps:
    1
    Resources:
    1
    Okay I've done some testing and determined the problem lies with this unit property:
    Art - Model File = Grunt, Gar'thok
    If I change that to something else, the noise goes away.
    And the noise is the Troll Headhunters Berserk sound.

    Does anyone have any idea how to make it stop?
     
  5. tml616

    tml616

    Joined:
    Apr 30, 2009
    Messages:
    337
    Resources:
    0
    Resources:
    0
    If it's based off Deathcoil and you don't have any "Art-Target," then the default art for Deathcoil will show when the fireball impacts. Just put a fiery effect in Art-Target and it should replace the Deathcoil one. Some things in the editor revert to default if you leave them blank, like buffs and art effects.

    The other thing where the Firebolt stun lasted forever is because you set the duration to 0. In the editor, 0 means infinity. So you could also fix this by setting the stun duration to 0.01. If you do this, the spell will stop any casting the target is doing. So if you want to avoid that side effect, you have to stick with Deathcoil or make a completely triggered projectile spell that doesn't stun.
     
  6. wolfman

    wolfman

    Joined:
    May 31, 2008
    Messages:
    696
    Resources:
    0
    Resources:
    0
    That should not be the problem. It should be the unit sound set that determines how your unit sounds. Sound - Unit Sound Set
    And for the stun thing, any time you set a value to 0 it will be permanent. So 0 stun = perm stun. Just set it to .01, but that will stop things like channeling abilities so i would use an ability that deals only damage if thats what you want. Maybe chain lightning that only hits one unit.
     
  7. Teelo

    Teelo

    Joined:
    Mar 31, 2009
    Messages:
    709
    Resources:
    1
    Maps:
    1
    Resources:
    1
    Yeah but I changed it from Grunt to "NONE" and all other sounds changed, but the Berserk sound didn't.
    Only thing that stopped the Berserk sound was changing its model!
     
  8. watermelon_1234

    watermelon_1234

    Joined:
    Nov 18, 2007
    Messages:
    1,066
    Resources:
    10
    Spells:
    9
    JASS:
    1
    Resources:
    10
    The only way to remove the sound would be
    1) edit the model to remove the sound.
    2) use a different model.
    It's because the berserker sound is supposed to play whenever the Grunt model uses its Spell Animation.
     
  9. Teelo

    Teelo

    Joined:
    Mar 31, 2009
    Messages:
    709
    Resources:
    1
    Maps:
    1
    Resources:
    1
    How would I go about doing that?

    Edit: Model editing is beyond my skill. Taking this to the request forum.
     
    Last edited: May 1, 2009
  10. Just_Spectating

    Just_Spectating

    Joined:
    May 16, 2007
    Messages:
    7,022
    Resources:
    46
    Models:
    11
    Icons:
    9
    Skins:
    26
    Resources:
    46
    did you just totally ignore my post or something? i said the same thing.
     
  11. Teelo

    Teelo

    Joined:
    Mar 31, 2009
    Messages:
    709
    Resources:
    1
    Maps:
    1
    Resources:
    1
    Actually I didn't understand your post.