• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • ✅ Time to vote for the top 3 models! The POLL for Hive's 6th HD Modeling Contest: Mechanical is now open! 📅 Poll close on July 16, 2024! 🔗 Cast your vote now!
  • ✅ The POLL for Hive's Texturing Contest #33 is OPEN! Vote for the TOP 3 SKINS! 🔗Click here to cast your vote!

[Crash] Techtree Requirements - Any Altar crashes game

Status
Not open for further replies.
So I'm trying to add an Altar to the techtree requirements for a building in my map, and for whatever reason, selecting either Any Altar from the Equivalents menu or an actual specific altar from the Units Menu and adding that to the requirements list makes the game crash as soon as I click on the building that requires an altar in order to upgrade. I removed the altar from the requirements list and had no crashes at all. Is there any explanation to this or any workaround that won't require more triggers and dummy research upgrades and all that?
 
I believe no base game unit have the any altar requirement which is probably why it could be broken without blizzard seeing it.
For example tier 3 town halls all asks for a particular altar and not for "any altar".
I've tried it with asking for a particular altar as well as "any altar" though, and both caused crashes :<

Have you tried copy/pasting the "Any Altar" field from an unit in the base game?
As far as I'm aware, I don't have any other units in the game that have an altar in their techtree requirements

Which version of warcraft 3 are you using?
Maybe in addition of finding a workaround you should file an error report?
was on 1.30.3, now on 1.30.4 but I haven't tried putting it back in after the patch because I doubt that it changed anything with that
Also, is there a manual way to file an error report somewhere? It didn't give me the usual error report box after the crash.
 
Level 14
Joined
Sep 28, 2011
Messages
968
Did you try copy pasting the requirement of the base melee tier 3 human town hall?
If it does crash I guess we will need at least a partial version of your map to test(but I use something like 1.27 so I would not be able to open but other people would be able to open)
 
Status
Not open for further replies.
Top