Playing a units animation via triggers

Bannar

Code Reviewer
Level 26
Joined
Mar 19, 2008
Messages
3,140
  • Animation - Play Triggering unit your_animation
Fill Triggering unit with your given unit.
In your_animation you have to type strings that refer to animations
For stand victory you have to type 2 strings:
Enter stand, victory. As you can see for entering more than one string, you need to type coma between them.
 
Level 2
Joined
Jun 30, 2011
Messages
9
doesn't work for this one.

  • Grunt
    • Events
      • Unit - A unit Begins casting an ability
    • Conditions
      • (Ability being cast) Equal to Grunt
    • Actions
      • Unit - Create 1 Grunt for Player 1 (Red) at (Position of (Target unit of ability being cast)) facing 90.00 degrees
      • Animation - Play (Last created unit)'s stand, victory animation
 
Level 29
Joined
Mar 10, 2009
Messages
5,016
then you have done wrong coz it works fine to me...
  • Untitled Trigger 001
    • Events
      • Unit - A unit Starts the effect of an ability
    • Conditions
    • Actions
      • Unit - Create 1 Grunt for Player 1 (Red) at (Player 1 (Red) start location) facing Default building facing degrees
      • Animation - Play (Last created unit)'s stand victory animation
EDIT: @Maker I've tested with coma..it doesnt work...
  • Animation - Play (Last created unit)'s stand,victory animation
EDIT 2: ok my bad, suppose to be have space "stand, victory"
 

Bannar

Code Reviewer
Level 26
Joined
Mar 19, 2008
Messages
3,140
I'm working with comma in animation triggers usually and they do work properly, don't know why you were thinking they don't mckill2009.
Just tested in editor while ago:
  • Animation - Play Grunt's stand, victory animation
Works properly, and via Warcraft3 model editor I'm sure that Grunt has Stand Victory animation.
However, comma is not required for animation to be played.

You have to have check conditions once again.
 
Level 2
Joined
Jun 30, 2011
Messages
9
waaaa.. its not showing up in my computer. is it because of WE?

EDIT :

fixed. its in warcraft video option. mine was set to low, thats why the animation won't show up.
 
Last edited:
Top