[SD/Modeling] Naga Merchant

Level 21
Joined
Sep 7, 2018
Messages
394
Hi friends✋
Can anyone add naga birth and death animation to goblin Merchant model?
image-bas.jpg
 
Level 30
Joined
Feb 27, 2015
Messages
370
Thanks, how you added water building under the birth animation?
if you mean the water pool NagaBirth attachment: just add an attachment point, copy&paste the path to one of them (they have several for some reason, some are different sizes) then adjust the visibility so it's only visible in birth sequence
c.png

if you mean the copy of main building that appears at the end of birth sequence: copy the meshes of main building into a separate geoset, made it move up and increase in size at the end of birth sequence and added global sequence & texture id animation
basically i opened two instances of magos: goblin merchant and naga building and then copied all the stuff that happens in naga building birth sequence and pasted it to goblin merchant
 
Level 21
Joined
Sep 7, 2018
Messages
394
if you mean the water pool NagaBirth attachment: just add an attachment point, copy&paste the path to one of them (they have several for some reason, some are different sizes) then adjust the visibility so it's only visible in birth sequence
View attachment 394688

if you mean the copy of main building that appears at the end of birth sequence: copy the meshes of main building into a separate geoset, made it move up and increase in size at the end of birth sequence and added global sequence & texture id animation
basically i opened two instances of magos: goblin merchant and naga building and then copied all the stuff that happens in naga building birth sequence and pasted it to goblin merchant
Thanks again.
 
for whatever reason none of the naga buildings had the "naga birth" attachment working when i was testing it in game but it worked fine in sanity tester
Depending on your Warcraft III version, the naga birth attachment file is in a different place. So this makes it hard to do a portable solution. You guys are lucky that you created a model that worked for both of your SD versions. When you make a Naga building custom model, you have to ask the question, what version is this Naga building model going to be used on?

Starting with Patch 1.29, the Naga birth model was moved to a different location. Historically on the Frozen Throne the model was located at "Buildings\Naga\NameOfStructure\NagaBirth.mdx". Each of the Naga structures had a copy of the birth model in their folder in the game installation.

The Reforged team who was working on Patch 1.29 to prepare for Reforged wanted to optimize and improve the game and didn't know a lot about the modding community technology. So they moved all of these birth models for the Naga into a single folder. In theory this is an improvement to the file structure of the game because it makes Naga formatted similar to Undead and Night Elf, and it makes the game installation smaller. Because of this change, on Patch 1.29 the Naga birth link file path is "SharedModels\NagaBirth.mdx".

However, after this patch, Kam who was working on Reforged team and also on his cool Beyond the Throne mod at the time reached out to me because he figured I was knowledgeable on these topics and he asked, why does this new patch 1.29 that his team is working on break all of the naga birth models in his custom map??

So back then I told him they have to support both paths now, because users might have already started making models that use "SharedModels\NagaBirth.mdx" as the path to their BirthLink now if they wanted to make a model specifically for Patch 1.29. I created a test map for their team to use with two copies of naga buildings -- one for each file path -- and I put in the map description notes that, basically:
- On Patch 1.28 and prior, the building on the left has a birth animation
- On Patch 1.29 and after, the building on the right has a birth animation

And I said, using this map, please create a future for Warcraft III where all fan-made Naga buildings models now have a birth animation.
This future is what you are seeing on the "Sanity Tester" since it loads Reforged data. In patch 1.30 or maybe it was 1.31, someone on Reforged team looked into my test map and they addressed this problem. [Edit: They created a redirect system where you get the space savings of Patch 1.29 by only having one file, but the legacy support of Patch 1.28 and before by supporting all file paths that resolve to the one true path.] But if you are using Patch 1.29 then you probably still are on the version that needs its own version-specific Naga building models, basically.

Edit:
There is a second problem if you use Patch 1.28 or before, or something like that, where due to a bug the birth models for Undead, Night Elf, and Naga in all cases do not appear. You may have also experienced that glitch based on your version. Without the game code of Warcraft III, I was never able to diagnose that old bug or why it happened, but I have not ever seen the issue on newer versions. So I believe it was fixed. In that case, that different bug happened due to an issue in the model loader for linked models, and they simply did not appear despite being properly configured. If you are having that bug, you will know because even the in-game models will not have their birth animation. You may note that in my description above, such as on Patch 1.29, the models inside the Warcraft III game -- the included Naga buildings -- all changed to match the game installation along with the patch. So it was only ever the custom models that were pulled out of the game's previous versions and modified that were broken by the file path stuff on Patch 1.29.
 
Last edited:
Top