[MAC] [Patch 1.28.5] Custom Campaigns not showing up

Level 1
Jul 13, 2017
I have a Mac OS Sierra and patch 1.28.5 Warcraft III Frozen Throne.

About a month ago I was playing Custom Campaigns, then I reset my PC and yesterday I re-installed Warcraft III.

I have two folder locations for my Warcraft III.
First one: /Applications/Warcraft III/
Second one: /Users/Shared/Warcraft III/

First one has launcher and similar items.
Second one only has folders with most of them empty.

The first folder didn't have /Campaigns/ folder inside of it.
The second folder had it.

I tried making /Campaigns/ folder in first location, but it didn't work.
I tried pasting custom campaigns in /Users/Shared/Warcraft III/Campaigns/ which also didn't work.

I read some people say that you should put campaigns in /My documents/Warcraft III/ folder, but I assume this is for windows.

I made a new warcraft III folder (copy second one): ~/Documents/Warcraft III/
I pasted campaigns inside ~/Documents/Warcraft III/Campaigns/ folder but they still don't show up.

I also tried putting them in scenario folders, in map folders etc. but nothing works.

I have no idea what to do next.

Can someone help me?