• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • ✅ Time to vote for the top 3 models! The POLL for Hive's 6th HD Modeling Contest: Mechanical is now open! 📅 Poll close on July 16, 2024! 🔗 Cast your vote now!
  • ✅ The POLL for Hive's Texturing Contest #33 is OPEN! Vote for the TOP 3 SKINS! 🔗Click here to cast your vote!

Issue with terrain.slk

Status
Not open for further replies.
Level 9
Joined
Jul 15, 2005
Messages
154
As of a few patches ago, putting a modified terrain.slk in TerrainArt\ no longer works. I've tried moving it to _retail_ as per Adding Shared Container Tech with Version 1.32.6 this thread -- which doesn't work either.

I've been using this to create a rock tile that is unwalkable so that I'm not placing a million pathing blockers. Is there a fix and/or alternative to this?

The weird thing is, my modified miscdata.txt seems to be importing correctly, but Terrain.slk does not.

Cheers
 
Level 9
Joined
Jul 15, 2005
Messages
154
I want to let anyone searching know that I finally solved this issue.

First off. you need to move your Terrain.slk into "retail/TerrainArt/Terrain.slk" within your warcraft III folder.

Then. you need to go into regedit and navigate to: HKEY_CURRENT_USER/SOFTWARE/Blizzard Entertainment/Warcraft III

If "Warcraft III" does not exist in that folder (for me it did not), right click Blizzard Entertainment and click New --> Key

Rename that new Key Folder "Warcraft III"

Within this Warcraft III folder create a new DWORD called "Allow Local Files". Set that DWORD value to 1.

Hey it works again.

Cheers
 
Level 18
Joined
Feb 25, 2013
Messages
317
That system is called Local files and they were always meant to require the registry key, which can also be seen if you try to do it in an older versions like 1.26. What should be noted is that _retail_ is the correct root folder for the Live version of the game and _ptr_ is the correct root for PTR. Also keep in mind that local files override map files.
 
Level 10
Joined
May 8, 2009
Messages
259
I want to let anyone searching know that I finally solved this issue.

First off. you need to move your Terrain.slk into "retail/TerrainArt/Terrain.slk" within your warcraft III folder.

Then. you need to go into regedit and navigate to: HKEY_CURRENT_USER/SOFTWARE/Blizzard Entertainment/Warcraft III

If "Warcraft III" does not exist in that folder (for me it did not), right click Blizzard Entertainment and click New --> Key

Rename that new Key Folder "Warcraft III"

Within this Warcraft III folder create a new DWORD called "Allow Local Files". Set that DWORD value to 1.

Hey it works again.

Cheers
Thank you! It worked like a charm!
 
Status
Not open for further replies.
Top