Disconnection Issues.

Level 3
Joined
Apr 26, 2009
Messages
31
Well I have been working on a game custom campaign called Farm Arena and It would be almost done but for some reason when someone dies in the game (besides the host) they get disconnected. Does anyone know why this is? Is it a problem with triggers or does this happen a lot with custom games? I have looked through all the triggers and tried redoing them, but nothing seems to help.

I just don't know what to do about this issue. Please post your thoughts and/or questions.

:fp:Oh and I will give you the map to look at if you seem like a trustful person.
 
Last edited:
Level 3
Joined
Apr 26, 2009
Messages
31
Im not stupid I deleted all of the main int. triggers.
It can't be my triggers because I have looked at everyone of them.

and I think I trust Pandizzle a little more then you anyways.

Ill give you a picture over msn but not here sorry...
 
Last edited:
Level 2
Joined
Aug 9, 2008
Messages
22
If you use GetLocalPlayer() at all this can sometimes cause desyncs depending on how you use it which might cause the dying player to disconnect. I believe the rule is that you can't use it with a function that returns a handle but I'm not sure. There's a tutorial on it here
 
Last edited:
Maybe it's your problem and not someone else's if your not trusting enough to show us anything here's what i suggest...

Create the beta and put it beta testing, then tell people to see if the bug happens to them. If it doesn't it's a problem with your comp if they do, you might have a coding error for the map as in blizzard has a buggie and your triggering it.
 
Level 3
Joined
Apr 26, 2009
Messages
31
Ok I deleted almost all the triggers and I have tried testing it on battle.net but it always comes out as them getting disconnected. The Triggers are not the problem I'm pretty sure.....
 
Last edited:
Top