• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • 🏆 Hive's 6th HD Modeling Contest: Mechanical is now open! Design and model a mechanical creature, mechanized animal, a futuristic robotic being, or anything else your imagination can tinker with! 📅 Submissions close on June 30, 2024. Don't miss this opportunity to let your creativity shine! Enter now and show us your mechanical masterpiece! 🔗 Click here to enter!

Aura Help

Status
Not open for further replies.
Level 2
Joined
Mar 3, 2011
Messages
16
Hello,

I am trying to make my map more neater and trying to balance out all the models to the same size. One issue I have is trying to get the aura size the same on all models. Since the aura increase to large circle when it goes over 1.00 in model scale size and goes to small circle when it goes below .60 I think.

Is there a way where I can make them all medium circle size aura for all model? Here is a picture so you can see the issue more clearly: http://db.tt/XSy8tS5

Thanks for your time and I hope someone can come up with a solution for my issue.
 
Level 26
Joined
Mar 19, 2008
Messages
3,140
Unit Editor -> select your unit go to field Art - Required Animation Names - Attachments and type: medium, large and nothing for small one. Not sure if 'small' works, but you can check it out.

You can check that for egzample footman got nothing there, while knight has 'medium'. It's easiest way to manipulate attachements size.
 
Level 2
Joined
Mar 3, 2011
Messages
16
I dont think it's possible to reduce/increase the aura size coz it depends on the size of the unit, a solution for this is Create a dummy unit with a model of an aura, then set the dummy's X and Y to the hero's position everytime...

See the map, but it need JNGP...

I could do that but then I would have to do that for couple of hero and there is a chance of them splitting up or not be in the correct position.

Unit Editor -> select your unit go to field Art - Required Animation Names - Attachments and type: medium, large and nothing for small one. Not sure if 'small' works, but you can check it out.

Not sure if I did it correctly but I added the medium string and it didn't seem to effect the aura size. I think that might be for effects and such.

or you can edit the model...

So far that is the only option I can see. However it would take a while editing a lot of models. Since after I increase the size of the model, I would have to fix the animation as well. Unless someone knows a faster/better way of doing it, you wisdom would be appreciated.
 
Level 2
Joined
Mar 3, 2011
Messages
16
There's a nice tool called Geoset Translation that can scale models among other things.
I don't think it really messes up the animations if you make the model bigger, though it's not as good if you need to shrink the model.

Wow, Ty so much. That tool just saved me soo much time. I was doing that manual in .mdl text.. +rep+love :)
 
Status
Not open for further replies.
Top