• 💀 Happy Halloween! 💀 It's time to vote for the best terrain! Check out the entries to Hive's HD Terrain Contest #2 - Vampire Folklore.❗️Poll closes on November 14, 2023. 🔗Click here to cast your vote!
  • 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • 🏆 HD Level Design Contest #1 is OPEN! Contestants must create a maze with at least one entry point, and at least one exit point. The map should be made in HD mode, and should not be openable in SD. Only custom models from Hive's HD model and texture sections are allowed. The only exceptions are DNC models and omnilights. This is mainly a visual and design oriented contest, not technical. The UI and video walkthrough rules are there to give everyone an equal shot at victory by standardizing how viewers see the terrain. 🔗Click here to enter!

War3 Editor is not behaving normally.

Not open for further replies.
Level 3
Oct 9, 2021
Hey hiveworkshop Community,

I am writing this here because during the use of Warcraft III World Editor i ran into a problem when trying to run one of my maps. i am trying to code in a text map that is not meant to be played on but meant for my studies as i am trying to learn the grammer of a different language, and i was using War3 editor to provide me the english part of it.

Anyway i am writing not because of my program(or map), but that fact is i cant seem to run a single code in that program, or at least a basic code. so i have uploaded 2 different maps. both have the same code in it that is suppose to run. at the start of the game i am suppose to see a random message that i wrote. okay the map that has my program on it doesnt work, not even after i disabled and turned off every other Trigger. for some reason it just doesnt work. okay so i create a new map with the same code and for some reason it works like it is suppose to. now if someone would be so kind as to open them up and tell me what i am doing wrong here. that would be wonderful.

-My map isnt working with basic or other code
-new map does work with same basic code
-need help getting my code to run properly so i dont have to spend days recoding everything

PS: i tried exporting and importing all the Trigger data, it didnt make a difference same problem.


  • Broken Map.w3x
    23.9 KB · Views: 12
  • working map.w3x
    12.3 KB · Views: 8
Not open for further replies.