• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • ✅ Time to vote for the top 3 models! The POLL for Hive's 6th HD Modeling Contest: Mechanical is now open! 📅 Poll close on July 16, 2024! 🔗 Cast your vote now!

Tooltip - Data reference only returns "0"

Status
Not open for further replies.
Level 3
Joined
Nov 12, 2018
Messages
43
I created a custom technology "R001:Rhme". Its sub data "mod2" has a value of "45" (Real, health increase per tech level).
I want to display this value in a tooltip from a custom ability. I already tried to display reference data from another custom unit in this abiity, which appears to be correct for some kinds of sub data only. Others are also displayed as "0" for no apparent reason.

I use the folowing tooltip: "test <R001,mod2> test"
I want to see: "test 45 test"
But I get to see: "test 0 test"

Are there rules to this, that I'm not aware of?

What I tried so far:
- "test <R001,mod2,%> test"
- "test <R001,mod2,.> test"
- "test <R001:Rhme,mod2> test"
- "test <R001;Rhme,mod2> test"
- There is no typo! "0" isn't "o" and "1" isn't "l" (lower case L)


*Note: The sub data "mod2" doesn't appear in the technology my custom technology is based of. Does this cause problems?
 
Last edited:
Status
Not open for further replies.
Top