• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • 🏆 Hive's 6th HD Modeling Contest: Mechanical is now open! Design and model a mechanical creature, mechanized animal, a futuristic robotic being, or anything else your imagination can tinker with! 📅 Submissions close on June 30, 2024. Don't miss this opportunity to let your creativity shine! Enter now and show us your mechanical masterpiece! 🔗 Click here to enter!

[Solved] Screen issue with WE, screen, dark interface? black?

Status
Not open for further replies.
Level 7
Joined
Jul 17, 2018
Messages
185
1687374971314.png


Hello everyone, any solution?
They gave me a laptop and I installed Warcraft 1.30 on it, I wanted to use WE but the screen comes out like this, no matter how much I zoom in or out, the funny thing is that you can put units or decorations because I hear that typical sound when I put or remove something from the editor. So:

-It's Windows 10 so I used OpenGL in the game and the WE, but it didn't work, only the game works normally but the editor doesn't.
-I changed the screen resolution from 1920x1080 to 1600x900 but that didn't work either.
-Change the text scale from 100 to 125 and it didn't work either.
-Use several types of compatibility but none...

Help I don't know what to do :goblin_cry:

Update:
I used v1.31 and at the moment it works normally, it doesn't crash or go black. I used the other older versions (1.27) and apparently only 1.30 has this error.
-I didn't use 1.31 because in melee games AI controlled heroes don't cast spells by themselves.
It was not what I expected but I am satisfied, I have no other choice :bored:

Thanks for your time
1687413329942.png


Update 2:

I did it! Yesterday I was not satisfied so I decided to search again for the solution and found it, apparently I just needed to put this in the shortcut path -graphicsapi Direct3D9 lol "a simple but unbreakable spell", however before that delete the world edit folder found in Registry Editor. Without further ado, problem solved.
 
Last edited:
Level 29
Joined
May 14, 2021
Messages
1,141
It's been a while seen I've seen anyone experience that annoying bug in World Editor, where 3D window/minimap/treeview location were simply retain the color of what was last displayed. There is a thread already about this kind of problem, which was quite old (it's 16 years), and if you attempt to open an existing map (or even made the completely blank one), WE will instantly crash for no reason. Basically, this problem happened because your World Editor doesn't handle your screen based on your resolution while it's maximized. This might be occurred if you have an external display with the resolution higher than your laptop has currently using on.

Another possible reason is that your video drivers (and even DirectX) seems to be corrupted for no reasons. If this is the right case, I highly suggest reinstalling the whole video drivers and DirectX completely from the scratch. Also, you might want to try the backup files for the latest version of Warcraft 3 (non-Reforged) as well (as that guy's above suggested), and check to make sure it's working without issues.

Talking about the game itself, current version of Warcraft 3 has its Widescreen support (16:9), but the main menu itself is still locked to 4:3 one with two black unused bars.
 
Level 7
Joined
Jul 17, 2018
Messages
185
It's been a while seen I've seen anyone experience that annoying bug in World Editor, where 3D window/minimap/treeview location were simply retain the color of what was last displayed. There is a thread already about this kind of problem, which was quite old (it's 16 years), and if you attempt to open an existing map (or even made the completely blank one), WE will instantly crash for no reason. Basically, this problem happened because your World Editor doesn't handle your screen based on your resolution while it's maximized. This might be occurred if you have an external display with the resolution higher than your laptop has currently using on.

Another possible reason is that your video drivers (and even DirectX) seems to be corrupted for no reasons. If this is the right case, I highly suggest reinstalling the whole video drivers and DirectX completely from the scratch. Also, you might want to try the backup files for the latest version of Warcraft 3 (non-Reforged) as well (as that guy's above suggested), and check to make sure it's working without issues.

Talking about the game itself, current version of Warcraft 3 has its Widescreen support (16:9), but the main menu itself is still locked to 4:3 one with two black unused bars.
Wow, 10+ years, I'll try to take those recommendations one step at a time. :c
 
Status
Not open for further replies.
Top