• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • ✅ Time to vote for the top 3 models! The POLL for Hive's 6th HD Modeling Contest: Mechanical is now open! 📅 Poll close on July 16, 2024! 🔗 Cast your vote now!

[Solved] Randomly not showing builds when unit clicking a unit to build

Status
Not open for further replies.
Level 31
Joined
Jul 10, 2007
Messages
6,306
I have a builder. I go to the build menu. I click on a unit. Sometimes, that unit doesn't show up for placement (nothing there). If I place that invisible unit, the game crashes.



Soo... what causes this and how do I fix it? I disabled all of the code in the map, so it's purely object editor related. It happens only with the larger buildings and it is totally random.


edit
Solved


The units being built by the builder had similar hot keys (noob early mappers >.>). This caused some issues... anyways, gave them all unique hot keys using the QWERASDFZXC pattern and now it works perfectly, bug gone. Now I must look through many towers to make sure that none of them share the same hot keys D:.
 
Last edited:
Status
Not open for further replies.
Top