• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • ✅ Time to vote for the top 3 models! The POLL for Hive's 6th HD Modeling Contest: Mechanical is now open! 📅 Poll close on July 16, 2024! 🔗 Cast your vote now!
  • ✅ The POLL for Hive's Texturing Contest #33 is OPEN! Vote for the TOP 3 SKINS! 🔗Click here to cast your vote!

[Solved] Problem with the 1.24b patch

Status
Not open for further replies.
Level 9
Joined
Apr 19, 2011
Messages
447
Hi.

I'm having a problem when I try to install the 1.24b patch for Warcraft III.
I have a lot of maps done with that version on my old computer.
I've bought a new computer, I've installed an older version, and I downloaded the 1.24b patch. But when I try to activate the patch, I receive an error with the war3.exe file. I can still play the game, but all the maps with imported models, imported music or imported pictures can't be played or opened with the editor.
Can someone help me to fix this problem? It's really important, because otherwise I won't be able to do any progress in my proyects.:goblin_cry:

Note: If this helps to solve the problem, my computer is a laptop, and I'm using Windows 7.

Regards
 

Dr Super Good

Spell Reviewer
Level 64
Joined
Jan 18, 2005
Messages
27,233
The lattest version of WC3 is 1.26. You should update to that.

Any maps you made with the old version should still be editable in the new version of the editor so all you need to do is remove all type casting bug use from the JASS scripts of your maps and they will be playable in 1.26.
 
Level 9
Joined
Apr 19, 2011
Messages
447
Is there a 1.26 version? I didn't know it!
Thanks for your answer. Anyway, I have never used JASS scripts, so I don't think that would be a problem. I'll try to update to that version, and then I'll check if it works. Thanks!

Regards
 
Level 9
Joined
Apr 19, 2011
Messages
447
The problem is solved.
I downloaded the 1.26 version, and the error message was still there when I tried to install it. I was a bit furious! Then, I tried to find something weird in the Warcraft III folder, and then I realized that the war3.exe was in "Only read" mode.
Of course, this was the source of the problem. Now I can install correctly the update, and I can open and play all my maps.

Conclusion: If someone has the same problem than me, check if the exe is in "Only read" mode. For me, it worked.

Anyway, thank you for trying to help.

Regards
 
Status
Not open for further replies.
Top