OpenGL Mode - Can't use Test Map Function

I'm using Windows 7 (x64) and Warcraft TFT wasn't working so I put it in OpenGl mode.
(Go to TFT Shortcut and add "-opengl" to the end of the target field)

After doing that it runs just fine, but I am unable to use the Test Map function in the world editor. I know this is because the -OpenGL is only being applied when I use that specific shortcut, and when running from the world editor it doesn't use that shortcut.

Does anyone know a way to fix this issue?

I tried looking for some kind of launch options from within the world editor (Like in steam), but was unable to find any.

(Edit): I am aware that I can just start up Warcraft TFT with the shortcut then open the map. But this takes much longer and I usually test my map after doing every individual thing to avoid bugs.