1. Updated Resource Submission Rules: All model & skin resource submissions must now include an in-game screenshot. This is to help speed up the moderation process and to show how the model and/or texture looks like from the in-game camera.
    Dismiss Notice
  2. The 15th Mini-Mapping Contest came to an end. The Secrets of Warcraft 3 are soon to be revealed! Come and vote in the public poll for your favorite maps.
    Dismiss Notice
  3. The 12th incarnation of the Music Contest is LIVE! The theme is Synthwave. Knight Rider needs a song to listen to on his journey. You should definitely have some fun with this theme!
    Dismiss Notice
  4. Join other hivers in a friendly concept-art contest. The contestants have to create a genie coming out of its container. We wish you the best of luck!
    Dismiss Notice
  5. Check out the Staff job openings thread.
    Dismiss Notice
Dismiss Notice
60,000 passwords have been reset on July 8, 2019. If you cannot login, read this.

New DestroyMultiboard bug in 1.30?

Discussion in 'Patch & Reforged Discussion' started by BizzaroFukuro, May 19, 2019.

  1. BizzaroFukuro

    BizzaroFukuro

    Joined:
    Dec 11, 2009
    Messages:
    88
    Resources:
    1
    Maps:
    1
    Resources:
    1
    Found this bug while fixing the good old RotD campaign.

    1. Create some multiboard.
    2. Destroy it:
    Code (vJASS):
    call DestroyMultiboard(mb)

    2. Enable letterbox mode
    3. Disable letterbox mode. As soon as the interface is fully shown, the game will crash. It probably tries to display the non-existent multiboard.

    Uploaded the example map for demonstration.
    Tested this in 1.30.4 - the game does crash
    Tested this in 1.26 - the game does NOT crash

    It can be avoided, if you hide multiboard before destroying it:
    Code (vJASS):
    call MultiboardDisplay(mb, false)
    call DestroyMultiboard(mb)

    Nonetheless, it needs to be fixed, as it didn't happen in older versions.
     

    Attached Files:

  2. BizzaroFukuro

    BizzaroFukuro

    Joined:
    Dec 11, 2009
    Messages:
    88
    Resources:
    1
    Maps:
    1
    Resources:
    1
    This bug is still present in 1.31.1.