Need help with skinning

You should attach the skin.

A lot of times it is due to an alpha channel issue. By default, I think Photoshop saves TGA's under 24-bits (unless you select 32-bits). Next time, select 32-bits. Also, when you are converting BLP's, I recommend using TGA's as they tend to be the most seamless in conversion (most similar in structure).

I recommend BLP Lab for all your conversions (it can even open up PSD files, iirc):
http://www.hiveworkshop.com/forums/tools-560/blp-lab-v0-5-0-a-137599/

Try reconverting it and then importing it again. Delete the texture from your map, save, close, reopen. Import the reconverted texture, save, and hopefully it should work.

If it does not show up at all (as in, the model uses the old texture), then check to make sure you put the correct path.
 
You should attach the skin.

A lot of times it is due to an alpha channel issue. By default, I think Photoshop saves TGA's under 24-bits (unless you select 32-bits). Next time, select 32-bits. Also, when you are converting BLP's, I recommend using TGA's as they tend to be the most seamless in conversion (most similar in structure).

I recommend BLP Lab for all your conversions (it can even open up PSD files, iirc):
http://www.hiveworkshop.com/forums/tools-560/blp-lab-v0-5-0-a-137599/

Try reconverting it and then importing it again. Delete the texture from your map, save, close, reopen. Import the reconverted texture, save, and hopefully it should work.

If it does not show up at all (as in, the model uses the old texture), then check to make sure you put the correct path.

Thanx, I tried all of this but i didn't work the problem is when i use War3ModelEditor and choose blp file from War.mpq and use it as a texture it works fine ingame but when i extract it and and import it in War3ModelEditor as a texture it doesn't work ingame even if i don't do any changes in it (i extract the file then import the same file). So the problem is something about importing the texture to War3ModelEditor. Please if you know someone who can fix this problem ask him how cuz i kept asking random people and posting this and no one answered this is driving me crazy. :'(
 
When you import a texture in War3ModelEditor, it automatically sets the path to the path in your hard drive.

For whatever reason, Magos' doesn't allow you to change the texture paths. You have three options.
  • You can save the model as .mdl with Magos. Open it in notepad and look for the textures block. Change the path of your imported texture. You can make it anything. Open it in magos and then save it as .mdx. Import it into your map and make sure that you imported the BLP with the proper path (the one you wrote down in notepad).
  • Get MDX Pather:
    http://www.hiveworkshop.com/forums/tools-560/mdx-pather-62978/
    Open your mdx, and change the path (e.g. if it is C:/Program Files/Warcraft III/Textures/SomeTexture.blp, you can just change it to SomeTexture.blp). Click the save button. When you import it into your map, make sure you import it with the proper path (ex: SomeTexture.blp)
  • The third option is just to import it with the ridiculously long path that is already there. When you import it into your map, you would just import it under the path that Magos shows. So if it is C:/Program Files/Warcraft III/SomeTexture.blp then you would import the BLP and the change the path to that.

When you import a texture into a model, it doesn't actually copy the texture. It just creates an association. It adds the path to the texture to its textures block. That way, when you import the model in your map, it will look in the MPQ for the texture to apply. If it can't find it, then it won't show up.

If you still have issues with it, then post the model and texture.
 
Top