• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • 🏆 Hive's 6th HD Modeling Contest: Mechanical is now open! Design and model a mechanical creature, mechanized animal, a futuristic robotic being, or anything else your imagination can tinker with! 📅 Submissions close on June 30, 2024. Don't miss this opportunity to let your creativity shine! Enter now and show us your mechanical masterpiece! 🔗 Click here to enter!

Map transitions not working after Loading a Save.

Status
Not open for further replies.
Level 3
Joined
Jun 21, 2017
Messages
31
Hello, I was working on my campaign with map transitions today and ran into an issue.

The map transition and game cache saving and loading works just fine when I play the campaign normally.
Problems start appearing when I try to Save and Load the game and then try to transition to the next map. Cause it just doesn't happen. Sometimes the game save refused to load altogether and the game just crashed.

I made a prototype campaign from my main one that features a Map transition identical to that used in my campaign and I run into the same problem. Once I Save an Load a save state the map transition stops working.

Could someone please look into what I'm doing wrong?

The prototype is very simple:
1. Kill Boss
2. Portal Appears
3. Use portal Ability
4. Map transition Occurs

Thanks for all help and advice in advance.
 

Attachments

  • Map Transition Prototype.w3n
    45.5 KB · Views: 29
Level 29
Joined
Feb 18, 2014
Messages
3,584
I can't tell what's wrong with your campaign unless I take a look at it, but judging by the length of your campaign name, I'd say that might be what's causing the problem. Try renaming your campaign to something shorter (Less than 13 characters)
 
Level 3
Joined
Jun 21, 2017
Messages
31
I can't tell what's wrong with your campaign unless I take a look at it, but judging by the length of your campaign name, I'd say that might be what's causing the problem. Try renaming your campaign to something shorter (Less than 13 characters)
I have made some progress but not much.
I can now get the prototype to work.
(After shortening the names it still didn't work)
But it turned out that for some unknown reason the unit which was responsible for casting the ability which caused the map transition to occur wasn't recognized by the game anymore after the load.
So I had to do a Generic unit event instead of a Specific unit event.

But another issue still stands which is that my main campaign (Not the Prototype which I sent) crashes the game whenever I try to load a save from it.

Edit: So I looked at the Error logs and all of the ones from the game crashing uppon loading the level Have "ACCESS_VIOLATION" as the Exception Summary if that is of any help
 
Last edited:
Level 3
Joined
Jun 21, 2017
Messages
31
Ok so i removed a trigger which Loads the Game Cache uppon the Save Being Loaded and it no longer crashes.

Am I not understanding Game chaches correctly?

In order to access the data from the cache it needs to be created anew each time the map is loaded isn't that right?
Or does the Save/Load system also save Game Cache and i simply wasn't aware of it.
 
Status
Not open for further replies.
Top