• 🏆 Texturing Contest #33 is OPEN! Contestants must re-texture a SD unit model found in-game (Warcraft 3 Classic), recreating the unit into a peaceful NPC version. 🔗Click here to enter!
  • 🏆 Hive's 6th HD Modeling Contest: Mechanical is now open! Design and model a mechanical creature, mechanized animal, a futuristic robotic being, or anything else your imagination can tinker with! 📅 Submissions close on June 30, 2024. Don't miss this opportunity to let your creativity shine! Enter now and show us your mechanical masterpiece! 🔗 Click here to enter!

Mac 2D Art Tools

Status
Not open for further replies.
Level 2
Joined
May 3, 2007
Messages
13
Included in this file are:
- A Macintosh compatible version of the MPQ2K
- A Macintosh version of the BLP Tools
- The lists of path names for both Reign of Chaos and The Frozen Throne

If you don't know how to use them, here is a very short and simple tutorial that I've written teaching people how to use them correctly..

I am not the creator of any of these tools. I compiled them together and wrote a tutorial on how to use them because they had gotten lost with the old wc3campaigns site. The author of the tools is Jean-Francois Roy (BahamutZERO) and is given all due to credits in the readme.
 

Attachments

  • Apple-logo.jpg
    Apple-logo.jpg
    4.9 KB · Views: 234
  • Art Tools.zip
    1.1 MB · Views: 261
Last edited:

Dr Super Good

Spell Reviewer
Level 64
Joined
Jan 18, 2005
Messages
27,232
Your post seems messed up, I can not see any jass on it. Please update and fix that since this would not be the jass submission fourm without submitting jass.

Read more carefully before spamming other peoples tools in the wrong section infuture.

Moved from jass submissions to tools.
 
Level 2
Joined
May 3, 2007
Messages
13
That's exactly what I'm trying to do. There used to be a Mac version of UMSWE available which I owned, but it got lost over time, and was only available on the old wc3campaigns site.
If anyone has got any other tools that are Mac compatible, please tell me about them and I'll create a Mac tools pack.
 
Level 2
Joined
Oct 24, 2007
Messages
21
I'm using Mac OS X 10.4.10 on a pre-Intel PPC 2.7ghz dual proc tower. Neither of the mac tools linked above (MPQ2K and BLP Tools) will work for me. Don't know if it's the OS version or what?

BUT - I found MPQ Extractor 1.0 (requires 10.4 and later) that works great:

http://www.devklog.net/2007/02/09/mpq-extractor-10/

Now i just need a graphic converter for blp to tga and back... I can't find one anywhere that works with my system. Anybody know of one? Or of a way I can get BLP Tools to work?
 
Level 2
Joined
Oct 24, 2007
Messages
21
OMG Sweet! Thanks Your Highness!

Is this app run through the terminal? Is it 'idiot proof' at all? I'm afraid of Unix shells and X11 and non-noobfriendly technobabble, lol. :D

.... but i will brave it to finally get to convert my tga's to blp, heh.
 
Level 2
Joined
Oct 24, 2007
Messages
21
Well macs are ftl for editing games basically you shoulda thought about that already

Thanks for the shrewd insight. Thank goodness my primary reason for buying a mac wasn't to use the World Editor or I'd really be screwed.

In spite of your revelation, though, I'd still like to find a blp - tga converter that works with the latest Mac OSX, so if you find one, post again. Otherwise, we already know Mac resources for the WE are hard to find. Reiterating that is not really very helpful.
 
Level 2
Joined
Oct 24, 2007
Messages
21
when i try to open MPQ2K Mac edition i get an "Application Launch failure" stating:
"the application MPQ2K could not be launched because of a shared library error <MPQ2K><MPQ2K><StormCarbon><>"

what does this mean? anyone know how to fix this?

Dunno what it means other than "somebody messed up a line of code", lol, but I get exactly the same error. Some type of clash with Mac OS X 10.4, I'm assuming?

ANYWAY: I found a Mac MPQ extractor that works!! Here's the link:
http://www.devklog.net/2007/02/09/mpq-extractor-10/

Not sure about 10.5 (most recent OS X iteration); I haven't upgraded yet. But it does work perfectly with 10.4.

Now if I could just find a blp<---->tga converter that works, I'd be in business.
 
Status
Not open for further replies.
Top